关于手册

世界之窗 TheWorld 2

使用手册

本手册以TheWorld 2.4标准版为依据对各个功能进行介绍，部分功能可能不在其它版本中存在。

2009.02

凤凰工作室版权所有


欢迎使用

欢迎使用世界之窗浏览器

欢迎使用世界之窗（TheWorld）浏览器

世界之窗浏览器是一款小巧、快速、安全、功能强大的多窗口Web浏览器，由凤凰工作室出品，完全免费，没有任何功能限制的绿色软件，兼容微软IE浏览器，在基于IE内核的基础上，独创的开发出很多有特色的增强功能。世界之窗浏览器不同于常见的其它IE内核浏览器，它使用C++和Win32 SDK开发，自行针对浏览器开发进行了代码库的封装，具有更扁平更透明的封装特性，功能实现的方法更加灵活快速。

本节内容

Ø TheWorld 浏览器 特性
Ø 程序使用许可
Ø 浏览器安装与卸载


软件特性

欢迎使用 >

软件特性

· 多线程窗口框架

世界之窗浏览器2.0版是继IE浏览器7.0版之后，世界上第二款采用多线程窗口框架的浏览器，区别于其它采用单线程的多窗口浏览器，多线程框架可以大幅减少由于某个网页假死导致的整个浏览器假死情况，并且可以在一定程度上提高网页打开速度。

· 智能广告过滤＋黑名单过滤

内建的智能过滤引擎可以有效的过滤自动弹出窗口、页面内自动漂浮广告，还您一个清净的浏览空间；如果您对广告过滤要求很高，世界之窗还提供了黑名单过滤，世界之窗浏览器的黑名单过滤采用直接从HTTP协议底层过滤的方法，配合内建支持的正则表达式，可以过滤任何您不想要的内容。

· 强大的浏览辅助功能

增强的地址栏输入提示功能，可快速匹配收藏夹或最近浏览器历史记录；过滤Flash、解除页面脚本对用户的限制、网页无级缩放、代理服务器快速切换、网页自动填表、快速保存页面内包括图片、动画、视频等任意内容、增强的页面内容查找和高亮功能、隐私保护、鼠标手势、自定义热键、地址栏自动完成、链接拖放等操作让您轻松浏览。 值得一提的是，世界之窗浏览器是第一款支持浏览器静音的浏览器。

· 不断加强的安全浏览

世界之窗浏览器独有的安全浏览模式，可以帮助您提高浏览安全，远离恶意插件的干扰，银行网站反盗号，网页防漏墙（页面执行木马警告），更多安全功能不断开发中...。后续版本将加入：适合不同国家用户的网站反钓鱼等。

· 性能优化模式

对于同时开启数十个页面，CPU占用率高的情况，世界之窗浏览器提供了性能优化模式，开启此模式后，CPU占用率可以瞬间降低并维持到打开一个单页面的水准，此模式对于网络浏览用户不存在兼容性问题。

· 内建支持多线程、断点续传下载

在众多浏览器中，世界之窗浏览器是为数不多的内建提供下载工具的浏览器。标准的文件名嗅探功能、多线程下载支持、断点续传支持、简单实用的下载管理，这些实用功能简单高效，内建下载与网页浏览的完美结合，可以极大的方便您的浏览和下载，为您节省了更多时间。

· 皮肤和插件

强大的皮肤支持功能，使您可以更换各种美观独特的皮肤，在世界之窗爱好者的帮助下，我们已经拥有了各种风格的经典皮肤供您选择；世界之窗浏览器支持和兼容IE内核浏览器的各种插件（目前暂时不支持工具条插件），扩展您的专业应用。


使用许可

欢迎使用 >

使用许可

世界之窗浏览器软件最终用户授权协议

世界之窗浏览器软件（以下简称本软件）受著作权法及国际条约条款和其它知识产权法及条约的保护。

本软件对于最终用户是免费的，您可以在遵循本协议的基础上自由的使用和传播它，您一旦安装、复制或使用本软件，则表示您已经同意本协议条款。

如果您不同意本协议，请不要安装使用本软件。

1.软件：软件是指世界之窗浏览器软件以及它的更新、产品手册、以及在线文档等相关载体。

2.限制：未经软件发布者许可，您不得对本软件进行逆向工程、反编译、反汇编以及任何形式的修改。您可以以任意方式分发数量不限的本软件的完整拷贝，但前提是：

①您必须提供完整的本软件版本，未经许可不得对软件乃至它的安装程序做任何修改；

②您不能因此而以任何方式任何理由收取费用；

③您不能够在商业性宣传活动、产品中附加本软件，除非您已获得著作权人的书面许可。

3.支持：软件会由于用户的需求而不断更新，著作权人将提供包括用户手册，电子邮件等各种相关信息支持，但软件不确保支持内容和功能不发生变更。

4.终止：当您不同意或者违背本协议的时候，协议将自动终止，您必须立即删除本软件产品。

5.版权：您需要清楚您只具备软件使用权，本软件受著作权法及国际条约条款和其它知识产权法及条约的保护。

6.隐私：世界之窗浏览器将不会收集您的隐私或者将它提供给任何第三方，如果有高级功能需要收集您浏览的网页信息，则该功能一定是可选的并且可以很容易禁用的。

7.免责：按照共享软件惯例，对于本软件安装、复制、使用中导致的任何损害，本软件及著作权人不负责任。


安装与卸载

欢迎使用 >

安装与卸载

系统环境

· 硬件配置：CPU 300Hz，内存 32MB，程序所需空间 ~ 3 MB
· 软件配置：TheWorld是运行在Windows系统下的32bit 程序，支持 Windows98/ME，Windows2000，WindowsXP/Vista；要求Internet Explorer 5.5及以上的版本。

版本说明

访问主页下载TheWorld：简体中文版下载页面，英文和其它语言版下载页面。可下载的版本有：

· 根据操作系统不同，区分Win9x和 Win2000/XP/Vista 版本，Win98系统不能使用其他系统的版本。
· 根据界面语言不同，可选简体中文、繁体中文、英语以及德语等十几种语言。
· 根据功能上的差别，可选择白金版、精简版（lite版）和UMPC版。白金版是在标准版基础上修改一些默认设置和自带一些插件和皮肤；精简版和 UMPC版是在标准版的基础上，简化界面及一些不常用的功能而成的版本，其中UMPC版是专为便携式PC设计的，点击这里可查看它们的区别。
· 根据安装方式不同，可选安装版和绿色解压版，相对安装版来说解压版是不创建快捷方式到桌面和开始程序组，不添加到“添加删除程序”中。解压版如果在Windows98/2000系统上使用，系统必须已安装了GdiPlus.dll动态库文件，如果没有，请下载GdiPlus.dll安装包安装。

安装使用

· 若下载的是安装版，直接运行安装程序，选择安装目录即可完成安装；
· 若下载的是绿色解压版，解压后将得到一个Theworld.exe文件，你无需安装即可直接运行它，不过我们强烈建议您在一个安全地方新建一个文件夹，然后把Theworld.exe文件移动进去，以便日后管理方便。当然，若想创建桌面快捷方式，可在此文件上右击选择发送到桌面快捷方式。

程序卸载

如果已设置TheWorld浏览器为默认浏览器，请先设置IE作为默认浏览器，然后：

*（注：请确保您存放在TheWorld目录下的私有数据已安全保存妥当）

· 若使用的是安装版，通过“控制面板”-“添加删除程序”来卸载程序。
· 若使用的是解压版且使用的新建文件夹，直接删除存放TheWorld.exe的目录即可。


开始使用TheWorld

开始使用 TheWorld 浏览器

现在，让我们开始世界之窗浏览器之旅吧。第一次启动，程序会检查默认浏览器，并询问你是否把浏览器设为默认。如果选择确定，那么TheWorld将会接管IE对网址或网页的处理，更加方便网上冲浪。

模式选择

在使用TheWorld之前，有必要了解浏览器几种运行模式。TheWorld提供了三种运行模式以适应不同环境下使用。各种模式的切换可以在‘访问按钮’上右击鼠标，或者在状态栏上选择切换。标签栏右侧将会显示当前使用的非标准模式的状态。

○ 标准模式
正常浏览，没有特殊设定（完整显示浏览历史、起始页记录、恢复列表等信息）

○ 公开场合模式
不显示恢复列表和历史侧边栏
关闭地址栏自动完成功能
不保存历史记录、输入过的网址等
此模式可避免以前的浏览记录被他人看到。尤其适用于演示

○ 隐私浏览模式
不生成Internet临时文件
不保存历史记录、输入过的网址等
产生的恢复列表项将在切换到其他模式时自动删除
此模式可避免此模式下的浏览记录以后被人看见。适合浏览个人隐私网站而不会留下痕迹

○ 启动参数

切换到隐私浏览模式或者公开场合模式后，重启浏览器后将自动切换回标准模式，如果要保持以某种非标准模式启动，可以在设置启动参数，比如在快捷方式的属性中，目标栏增加参数（参数前有空格）: -pv（隐私浏览模式）或者 -pb（公开场合模式），如图：


程序主窗口功能

开始使用TheWorld >

程序主窗口功能
显示/隐藏 被隐藏的内容

程序主窗口功能

如图，在菜单的 查看>工具栏 中勾选所有工具栏，我们可以看到以下不同功能区块，在此就依图中序号对其功能区块进行简要介绍。

功能导航

1) 标题栏和菜单栏
2) 标准按钮工具栏
3) 地址栏和搜索栏
4) 收藏栏和小工具栏
5) 侧边栏
6) 标签栏 和 网页内容窗口
7) 查找栏和状态栏


标题栏和菜单栏

标题栏和菜单栏

在界面上，默认的标题栏和菜单栏布局不同于常规的Windows窗口风格。此风格被称为“多功能标题条”风格，这种标题和菜单合用一行的风格目前已被广泛应用，因为它能节省出一行的空间。

标题文字：可选是否显示当前页标题；字体可设置是否使用粗体。在高级选项中可分别设置它们：在地址栏输入 tw:conf 回车（即工具>选项>高级选项）

＊浏览设置>基本设置>在浏览器窗口标题栏上显示当前页面的标题

＊其它>杂项>多功能标题条使用粗体文字显示

菜单栏和窗口控制按钮：菜单栏可设置隐藏，在状态栏等工具栏上右击勾选菜单栏；菜单栏功能可自定义快捷键，更多查看自定义快捷键。

窗口控制按钮区分鼠标左击和右击，它们对应着不同功能，鼠标指针悬停其上可查看其功能的描述信息。

窗口风格设置：要恢复到Windows窗口默认风格，在地址栏输入 tw:conf 回车（即工具>选项>高级选项），取消勾选：常规>基本设置>使用多功能标题条。


标准按钮工具栏

标准按钮工具栏

标准按钮基本都提供左右键功能，同样悬停鼠标可得到左右键的功能描述信息。

自定义按钮：可设定某个按钮显示与否。菜单 查看>工具栏>自定义工具条按钮>标准按钮。只能对已有的按钮进行删减，例如我们还可以添加一个“新建”按钮。

新建按钮：右击新建按钮可打开剪贴板中的网址，若剪贴板内容并非网址，则会在当前搜索引擎搜索该内容。

主页按钮：TheWorld允许设置多个主页，右击主页按钮可打开全部主页。

高级选项>常规>首页设置，多个首页之间使用回车换行

恢复按钮：当浏览的页面因误操作被关闭，点击此按钮可撤销刚才的动作，右击按钮弹出恢复列表，您可选择要恢复的页面。恢复列表中的数量可在高级选项设置，如下图。在恢复列表上，使用鼠标中键点击链接，列表不会关闭以便可选择性地恢复多个链接。


地址栏与搜索栏

地址栏与搜索栏

在 高级选项>地址栏和搜索栏 可设置此区块很多功能（如地址栏搜索和自动完成，网址别名等）。

地址栏输入模式智能完成

在 高级选项>地址栏和搜索栏>基本设置>启用增强的地址栏输入提示(需要重启浏览器) 下可启用此功能：当在地址栏输入内容时，TW将自动搜索收藏夹和历史记录中匹配输入内容的链接，如下图。下拉列表显示模式可点击右下方的按钮切换。

地址栏和访问按钮：如果剪贴板内容是网址，可在地址栏上右击鼠标，选择‘粘贴并访问’则直接打开网址。右击访问按钮，可选择更多功能，如下右图：

在地址栏的字符组，有时并不想把它作为网址来访问，比如上图的 [ www.baidu.com ]，只想在搜索引擎中搜索这个网址，此时，可右击访问按钮，根据需求选择不同功能。

· 访问：若地址栏中为网址或网址别名则访问它们，否则使用当前引擎搜索它们。如果网址已经打开，将会再次打开此标签页的副本。
· 搜索：将使用当前的搜索引擎搜索这个字符组。
· 访问剪贴板中的网址：剪贴板中内容如果是网址或有网址符号（比如斜杠），将会在新标签页打开它（们）；如果是常规字符组，则使用当前搜索引擎在新标签页中搜索它（们）。如果剪贴板中内容可以是多行文字时，将只处理第一行。
· 使用IE浏览器打开当前网页：多种因素造成某些网页可能无法在TheWorld中正常显示，此项可快速切换到在IE中显示当前网页。
· 标准模式等：浏览器模式快速切换，比如选择‘公共场所模式’，浏览器会隐藏地址栏下拉列表的历史记录。更多关于浏览器模式的内容…
· 删除下拉列表里其中一个记录：鼠标指针停留在想要删除行的位置，按下 Del 键即可删除它。

地址自动完成和网址别名（快捷网址）

· 在 高级选项>地址栏和搜索栏>地址框自动完成 下可自定义使用快捷键自动补齐网址的前缀和后缀，这样我们只需输入地址的部分内容即可快速完成的网址，如下左图。
· 在 高级选项>地址栏和搜索栏>网址别名 下可设定网址别名（快捷网址），如下右图，在地址栏输入tw回车即可访问TheWorld论坛。快捷网址如同热键网址一样，可以同时对应多个地址，之间可以用分号(;)分隔开，若是对应文件夹路径，路径的空格使用%20代替。（注：别名名称不区分大小写，重复时取首个设置的网址）

搜索栏：搜索栏包括搜索输入框和搜索按钮，聚焦输入框时按下回车即执行搜索行为，等同于点击搜索按钮。搜索按钮可自定义不显示。

· 搜索栏宽度：搜索栏的宽度可直接在界面上调整，如下图，也可以到选项中：高级选项>地址栏和搜索栏>基本设置>搜索栏宽度 定义其宽度值。

· 搜索引擎的自定义：点击搜索栏输入框内左边的图标（即搜索引擎图标），将弹出搜索引擎列表，当切换搜索引擎时，如果搜索栏输入框中有内容，浏览器将自动使用新的搜索引擎搜索该内容，此项功能可在搜索设置中关闭，如下左图。在列表的某个搜索引擎上右击鼠标，可指定某种拖拽动作对应启用搜索引擎或者禁用这个搜索引擎，如下右图。

· 强制搜索：将选取的文字，拖放在搜索输入框，即执行强制搜索，选取文字无论是否为网址。

· 搜索引擎的添加修改：如上右图。详见 高级选项>地址栏和搜索栏>搜索引擎，或搜索引擎自定义。
· 搜索引擎快捷词：在高级选项>地址栏和搜索栏>搜索引擎 的搜索引擎列表中有一栏是快捷词，如果某个搜索引擎定义了快捷词，那么您可以在地址栏 上按‘快捷词 关键字’（不含引号）的格式输入关键字来指定使用该搜索引擎搜索，而无需切换当前默认的搜索引擎。


收藏栏和小工具栏

收藏栏和小工具栏

此功能区主要便于我们操作使用频率很高的网站和贴心功能，小工具栏自定义方式和其他工具栏一样，可根据喜好隐藏一些按钮。

收藏栏是收藏夹的一个衍生物（默认快捷键Ctrl + B显示/隐藏 收藏栏），基本上继承其所有的功能属性，本质上没有任何差别。不同的是：收藏栏仅限于一行，收藏项目不能拖动排序，超出一行即可拖动排序，收藏栏项目的自定义排序是在收藏夹中拖动项目完成的；收藏栏路径可有别与收藏夹路径（默认使用同一路径）。更多参考收藏夹设置…


侧边栏

侧边栏

显示/隐藏侧边栏的方法很多，可在菜单的查看工具栏里调出，也可以点击侧边栏按钮，或者使用快捷键Ctrl+Shift+S ，甚至还可以点击状态栏最左边不起眼的小按钮实现。

在侧边栏顶部，是配置侧边栏的主要按钮，如下右图，侧边栏可切换多种功能，功能可通过侧边栏插件来增加；小按钮主要设置侧边栏风格以及侧边栏自动隐藏、显示在窗口左侧或右侧等。

侧边栏-我的电脑：这是一个集成在浏览器内部的资源管理器，如同WindowsExplorer，可在多个标签页打开文件夹，不同文件夹之间的文件操作更加方便。

侧边栏-历史：提供历史记录查找和删除功能，历史记录按钮只在小工具栏有，历史记录默认按名称站点排序，目前不能选择排序方式。

侧边栏-收藏夹、下载管理：相关内容查看收藏夹，下载管理


标签栏
显示/隐藏 被隐藏的内容

标签栏

这个区域是浏览器的核心部分，从Internet上获得的信息需要经过多重处理后才是我们想要的，在巨量信息面前，要想快速的处理，就得把大部分的处理操作集中在这个区域内完成。因此扩展键盘和鼠标操作在页面中的功能就显得非常重要了，毕竟其它区域的按钮、菜单与鼠标指针有一点距离。

标签栏-新建标签按钮：该按钮可隐藏：高级选项>标签栏>显示>在标签栏左侧显示新建标签按钮。左击该按钮新建一个空白标签；右击‘访问剪贴板中的网址’，前面在介绍右击访问按钮时提及到该功能，点击查看…

标签栏-控制按钮：控制按钮可设置隐藏：高级选项>标签栏>显示>在标签栏右侧显示控制按钮。

控制按钮上均有左右键功能。左击标签列表按钮：显示所有打开的标签页缩略图，其中缩略图项标题是粗体的为当前活动标签，如下图黄颜色画框处。点击某缩略图则浏览该标签页，缩略图大小可使用右上方拉杆调整；右击标签列表按钮则以列表形式列出已打开的标签页。

标签栏-页面标签：页面标签上默认显示网站图标，网页标题，激活的标签上还显示关闭按钮。图标和关闭按钮可隐藏不显示，未激活过的标签页网页标题可定义字体颜色和粗体风格，这些均可在 高级选项>标签栏>显示中设置。

标签宽度设置

标签宽度可选两种算法方式，在高级选项>标签栏>动作>限制 下设置，其中经典样式是指定在宽度限制范围内，标签可根据页面主题文字长度智能调整宽度，也就是说各个标签可以是不同宽度；而简单样式是指各个标签平分当前浏览器窗口的标签栏长度，直到达到最小宽度限制。

标签锁定

锁定标签可防止它因误操作被关闭，标签若被锁定，任何执行关闭它的操作，都会被提示标签已锁定，是否要关闭的信息对话框。右击标签在弹出菜单选择锁定解锁标签，还可以点击标签上的图标切换锁定解锁状态（此项默认关闭，要启用请勾选：高级选项>标签栏>动作>点击标签图标，锁定解锁标签）。若退出程序时有锁定标签，下次启动时将自动打开它们。

标签关闭

在 高级选项>标签栏>动作 中可设置双击左键和中键点击关闭标签，还可设置右击关闭标签（按 Shift键时右击则忽略，弹出菜单），也可通过鼠标手势关闭。默认双击关闭标签。

标签隐藏

在标签栏上滚动鼠标滚轮或点击标签控制向后按钮，可把标签隐藏到左边。

标签切换

激活标签是多式多样的，具体可在高级选项>标签栏>动作 中设置，其中鼠标悬停激活标签是TheWorld一个亮点，当鼠标指针停留在标签上达到指定时间，即激活该标签。当然，您也可以使用鼠标滚轮在标签栏滚动实现标签切换（此两项默认关闭，要启用须先勾选：高级选项>标签栏>动作>在标签栏上滚动鼠标滚轮时，切换标签 和 鼠标悬停在标签上 毫秒，自动激活该标签）。某些键盘或鼠标上有<前进>和<后退>扩展键，可在高级选项>高级>杂项>将<前进><后退>两个扩展按键作为标签切换键。

标签拖拽

按下鼠标左键拖动标签，在标签栏上移动是切换标签排列顺序；若拖到‘新建’按钮上，则是复制该标签，这是除 右击访问按钮>访问 复制标签外的另一种方法；若拖动页面中，则是将标签页弹出为置顶、窗口功能。

标签自动刷新

右击标签在菜单中选择自动刷新设置刷新频率和刷新方式。新设置的刷新时间只对下次启用自动刷新时有效。

标签分屏设置

很多网页为了兼容旧的显示器把宽度限制在800pixels，在宽屏显示器上显示这些网页两边会空余很大面积，如何充分利用这些面积，也是浏览器要考虑的问题。TheWorld浏览器可以设置多标签页同时垂直显示，最多允许三个标签页同时显示。使用Ctrl+左击标签 来切换分屏显示模式。已显示的标签和未激活的标签是有细微差别的，如图。拖拽链接到另一个分屏窗口，链接将在这个分屏窗口打开，而不是新开标签页。


网页内容窗口

网页内容窗口

本部分内容主要介绍鼠标和按键动作在网页中的丰富功能。这些功能的实现很大比例是靠鼠标手势实现的，强烈建议您了解鼠标手势，掌握基本的手势动作。

本节内容

Ø 文字和链接操作
Ø 页面内容的保存
Ø 页面显示（如填表等）


文字和链接操作
显示/隐藏 被隐藏的内容
文字操作
· 拖拽文字：鼠标选取一段文字，按下鼠标左键，拖动文字，再放开鼠标，这就是拖拽文字。（文字选取后，按下快捷键Ctrl + R等同于拖拽文字）

o 拖拽文字时，将使用当前的搜索引擎搜索选取的文字。此项功能可关闭。
o 拖拽方向区分向左和向右，向左拖拽可设置把文字复制到剪贴板中。该功能默认未启用，要启用请勾选 高级选项>鼠标动作>基本设置>当向左拖放文字时，将文字复制到剪贴板。
o 以上操作，限制选取的文字不得多于64个字符，超过则跳出将选取的内容保存为文本文件的窗口。此限制可关闭 高级选项>鼠标动作>基本设置>当拖放的文字超过64个时，弹出保存对话框提示保存。
o 选取内容含某些符号（如斜杠）将被判为网址，要强制搜索请拖拽文字到搜索输入框。

· 复制文字：某些网页对文字复制作了限制，一般表现为不能选取文字，不能使用右键菜单等。由于限制手法是各有不同，因此解除这些限制方法也是多样的，总的来说都与广告过滤有关。
o 解除限制可启用 高级选项>广告过滤>解除页面脚本对操作的限制 下面的选项。启用这些选项可能存在页面兼容问题，表现为：银行页面输入密码的软键盘粘着鼠标走；网页中电子地图也是粘着鼠标不能被释放，解决方法加入该网站为信任站点或者关闭这些选项。
o 使用编辑模式查看网页：菜单 编辑>用编辑模式查看。 此方法能解决~99%的页面所设的限制。编辑模式也是TheWorld一个亮点，查看更多关于编辑模式的信息…
o 使用插件，如 Mouse Unlock.7z LiquidLayout.zip 清除水印等。一些页面允许复制内容，但得到的内容里有很多乱码，这就是加入了隐藏文字保护机制，借助插件可清除这些隐藏乱码。
o 使用广告过滤名单，这需要您熟悉网页代码和过滤代码。当然您可以到论坛发帖求助。
链接操作

概括对链接处理的几种方式，大致是在当前标签打开，在新标签打开，打开后激活，打开后不激活，本地的文件以及外部程序上的链接打开。

· 在新（当前）标签中打开链接：网页内的链接，不能使它强制在当前标签打开，但部分可以强制在新标签中打开。对于外部程序调用的链接只能在新标签页打开。
o 按下 Shift+点击链接 可强制在新标签打开（部分链接可能无效）
o 可设置强制在新标签打开：高级选项>鼠标动作>基本设置>左键点击链接时，总是在新标签打开链接（会有兼容问题，不推荐普通用户使用）
o 首页、地址栏和搜索框中输入的地址在新（当前）标签打开的设置：高级选项>浏览设置>高级>使用新页面访问 下面的选项根据喜好选择。
o 收藏夹（栏）中的项目访问，高级选项>收藏夹设置>高级>使用新标签访问收藏夹中的网址（否则使用当前标签）
o 鼠标中键点击链接将在新的标签页打开，此项需要勾选：高级选项>鼠标动作>基本设置>中键点击链接时，在新标签打开链接。
o 拖拽链接以及拖拽文字搜索时将在新标签页打开。

o 外部程序调用的链接将在新标签打开。若浏览器是关闭（隐藏）状态，可选打开时不显示首页、起始页等：高级选项>常规>启动时>对于外部调用，启动时不显示上述页面（此项仅对已设为默认浏览器有效）。

· 在前（后）台打开标签：在 高级选项>浏览设置>基本设置>前台显示新打开的页面 可定义是否激活新打开的标签，此选项也可点击状态栏按钮快速切换前后台显示状态。

下列几种情况不受此选项影响：

o 拖拽文字强制搜索时，标签将在前台显示。
o 鼠标中键点击链接前后台显示的控制见选项：高级选项>鼠标动作>基本设置>中键点击链接时，在新标签打开链接。
o 拖放链接时分向左拖放和向右拖放，前后台状态可根据方向不同来设定：高级选项>鼠标动作>基本设置>拖放链接时，在新标签打开链接>向右拖放时，后台打开链接;向左拖放时，前台打开链接。此时若某链接已被打开，向右拖放它则激活该标签。
· 拖拽页面中的链接到地址栏：页面中的链接可拖拽到地址栏以便编辑。
· 页面中图片的链接复制：在图片上右击鼠标，选择复制图片地址，图片链接将被保存到剪贴板中。


页面内容的保存

页面内容的保存

前面我们在文字操作中已介绍了页面内文字的保存，这里介绍网页元素及整个页面的保存。页面元素主要是音频、视频和图片。保存网页中的元素时是不能改变文件类型的，原始是什么类型的文件，保存后还是一样，不会因为命名扩展名不同而改变。

· 网页元素保存:快速保存功能的设定在 高级选项>鼠标动作>保存页面元素 下的选项，根据您的喜好设置选项。
o 当启用提示方式保存后：按下 Ctrl+Alt+左击页面元素 将出现元素保存窗口。比如页面上Flash视频的保存，按住Ctrl+Alt不放，然后在视频上点击，如图：

o 当启用自动保存方式后：按下Alt+左击页面元素 将自动保存元素在指定文件夹中，默认设置使用相对路径Medias（即TheWorld安装目录下的medias文件夹）。路径设定：高级选项>鼠标动作>保存页面元素>自动保存路径。保存成功后会在状态栏上显示提示信息：

o 若页面的元素还在加载中，执行以上操作，将得到元素的地址而非其本身。

o 并非每一次我们都能轻易得到我们想要的媒体文件。现在网上很多媒体真实地址都隐蔽的很好，如flash视频大都调用flv文件，简单保存这个SWF文件是没有用的，这时就需要先得到媒体的真正地址，打开 工具>页面元素查看器 就能帮我们解决这个问题。

· 网页保存：除了继承IE常规的保存方式，TheWorld能把网页保存为图片。对于那些很长的网页要保存为图片，常规的截屏软件是无法做到的，而TheWorld可满足不同需求。
o 保存网页为图片：选择菜单 文件>保存为图片 或者快捷键 Ctrl+M 即可把页面保存为图片，格式可以是PNG、BMP、JPG文件。
o 编辑模式：选上菜单 编辑>用编辑模式查看 后，我们可以对页面进行简单修改。要保存修改结果，为了确保无误，建议保存为图片或者打印。通过PDF打印机，我们可以把修改后的页面直接打印成PDF文件。（注：由于页面的复杂性，不少页面将会在编辑模式下无法正常显示；同样若保存为网页格式有可能无法得到是修改后的效果）


页面显示
显示/隐藏 被隐藏的内容

页面显示

页面显示主要包括页面元素的隐藏、页面缩放以及页面背景字体的修改。

页面元素隐藏

在页面元素加载选项中，不同于IE的是可选择不显示Flash，还有如不勾选播放页面声音，是真正的浏览器静音效果，不会影响外部程序的声音。它们都可在状态栏上点击相应按钮快速开/关，如图。（如果您遇到浏览器没有声音，不能播放Flash视频，请留意是否误点了它们）

页面缩放

如下左图，状态栏缩放按钮上预置几种页面缩放比例，点击可循环切换。更详细的设定在 高级选项>浏览设置>高级>全局网页无级缩放比例__ 和 新开启的网页使用和父级网页相同的缩放比例 两个选项。

选上 高级选项>鼠标动作>基本设置>按住Ctrl键滚动鼠标滚轮，无级缩放网页（按住Ctrl+Alt滚动滚轮恢复） 可更方便控制页面缩放。

页面背景和字体

这些除了在 Internet选项>常规>字体 和 辅助选项 中定义外，TheWorld中还可以已通过插件或者黑名单过滤规则来实现改变，使用黑名单过滤替换CSS法需要熟悉广告过滤机制，详情参考广告过滤介绍。

错误页面显示

当访问无效网址时，浏览器会返回404错误信息或者其它错误信息显示在页面上，如果不能得到网站自定义的错误信息页面，TheWorld浏览器将会显示一个友好的错误页面。该选项可关闭 高级选项>浏览设置>基本设置>当网站出错的时候显示友好错误页面 ，如果关闭则调用系统默认设置。

· 如果访问的链接无效或者是由于网速慢造成严重超时时，[比如http://www.ioage.com/tttteeesssttt.html]友好错误页面表现为如下图：

· 如果访问的是无效域名的链接（比如http://13124242.com）时，可能得到一个来自网络运营商的错误页面（如中国电信，是114的报错页面，见下图）。该错误页面的取消显示需要联系您的网络运营商，这与系统和浏览器设置无关。

起始页面设置

起始页面是程序启动后所显示的页面，相关设置为 高级选项>常规>启动时 下的选项。程序安装（或版本升级）后首次运行，将会打开一个欢迎界面，此页面可以帮助您快速配置浏览器设置。起始页相应的选项如图：

· 若取消选择所有选项，程序启动后将是一个空白页。空白页支持自定义背景图：把图片放到TheWorld.exe所在目录，命名为 logo ，图片类型可以是PNG、JPG、GIF文件格式。

· 若启用以列表方式显示，在退出程序时未关闭起始页和其它标签页，那么下次启动时其它标签页将会追加在上次的列表中。起始页可以通过在地址栏输入 tw:home 调出，起始页上可以显示每日提示信息，对应选项为 高级选项>其它>杂项>在欢迎页面上显示每日提示信息。

· 起始页面可定义上网快速入口，点击‘设置’您可以自定义在起始页面上添加常用的网站。且在右上角的控制按钮可随时切换上网快速入口、上次退出时未关闭的页面和每日提示信息的显示与否，程序下次启动会记住它们的显示状态。

页面内容拦截

前面已提到页面中不加载一些元素（如Flash、声音等），而这里说的内容拦截是指简单广告过滤设置，主要指弹出窗口，漂浮元素。其对应的选项为 高级选项>广告过滤。（注：过滤设置可能会造成个别页面不能正常显示，此时您可以关闭此类选项，然后再按下 Ctrl+F5 重新加载页面试试）

· 如果设置了拦截弹出窗口，我们可在右下角查看被拦截的链接，您可点击它临时允许弹出，也可以把网站添加到白名单，总是不拦截此站点的弹出窗口。

· 漂浮元素过滤：某些页面上总是漂浮着一个信息框，遮盖我们想阅读的内容，影响正常浏览，此类信息多为广告内容。TheWorld浏览器默认过滤这些信息，加强此类过滤请选上 高级选项>广告过滤>特殊广告过滤>过滤全屏漂浮物和ICast广告（新页面生效）

· 若启用 不显示网页中的Flash动画 ，则Flash不会被下载。这样可节省您的网络带宽和流量。此选项点击在状态栏上对应小按钮快速切换开/关。

页面表格填写

填写表格网络上经常要遇到事，而同一类表格的格式基本大同小异，如帐号注册表格。如果我们事先设定几个表格模板，当遇到要填写表格的页面时，直接调用，那将会省事多了，因此自动填表功能应运而出。在TheWorld中，可以在菜单中调出此功能，也可以在地址栏输入 tw:form 调出自动填表设置。

· 自动填表设置：使用自动填表功能之前，要先完成至少一个通用表单。
· 当浏览到要填表页面时，可按快捷键Alt+W，页面相应栏目就自动完成输入通用表单预置的内容。（注：快捷键Alt+W只适用于首个通用表单，其它的需自定义设置快捷键）

· 针对指定URL表单的填写：先完成该页面的表格输入，然后在提交之前，我们可以先保存该表单（快捷键Alt+1），这样当下次再次访问该页时，直接在菜单中选择“填写当前表单”（或快捷键Alt+Q），就可以完成输入。相比调用通用表单的填表方式，这种填表方式更具有针对性，不存在因栏目的不匹配而无法完整填写的问题。


查找栏和状态栏
显示/隐藏 被隐藏的内容

查找栏和状态栏

当按下快捷键 Ctrl+F 后，可以发现查找栏显示在浏览器下方。查找栏和状态栏的位置是不可移动的，但是可以隐藏它们：菜单 查看>工具栏。其中查找栏使用快捷键Ctrl+F 来切换显示/隐藏状态。

查找栏

比起IE浏览器，TheWorld浏览器的查找功能有所加强，显示方式也有所不同，现在我们一起来了解一下TheWorld的查找功能用法。

更多内容...

· 若按下快捷键 Ctrl+F 显示查找栏，则直到再次按下该快捷键或者点击关闭按钮后才会隐藏。
· 输入的内容若含‘空格’符号，将被智能拆分为多个关键字，此时可部分匹配搜索（如下图，点击2、3处内容）。
· 点击高亮按钮将以不同颜色分别标记拆分后的关键字。
· 聚集输入框回车时即执行查找行为，持续回车动作即是向下循环查找输入内容。
· 鼠标左击关键字是向下查找，右击关键字是向上查找。如要查找符号%，请输入双百分符号，即%%。

如图，当在“页面过滤”间增加空格，右边关键字处即多出图中2和3部分，左击和右击可按不同方向查找。

状态栏

在前面已提过，点击状态栏最左边处可显示侧边栏，如下左图画框处。状态栏右边预置一些小按钮，鼠标指针悬停其上可获得其功能的信息描述。一些状态栏插件也会在状态栏上显示。

更多内容...

· 状态栏上信息
v 很多在页面上的操作都会在状态栏上有信息提示，如 鼠标指针移动到链接上会显示链接地址；再比如 Alt+左击媒体 自动保存成功后，就有如上右图提示。
v 有些网站自定义了状态栏代码，您可以通过此选项过滤此类代码的效果：高级选项>广告过滤>状态条文字过滤>状态栏上只显示Url网址信息，过滤网页的文字状态信息。
v 当移动窗口位置或者调整窗口大小时，状态栏左边显示坐标信息（X-Y，W-H），如上左图。
· 自定义状态栏项目：在状态栏上右击>自定义工具栏>状态栏 打开工具栏自定义窗口，按您的喜好添加删除项目以及它们的排序。


程序窗口控制

开始使用TheWorld >

程序窗口控制

程序窗口控制

除了常规的窗口模式，TheWorld浏览器还有最小化到系统托盘区和隐藏窗口（通常称为老板键功能）。

2.2.1 全屏模式

右击最大化按钮或者按下功能键F11 可切换全屏模式。在全屏模式下，鼠标指针移到屏幕顶端边缘，可显示工具条。全屏模式下设置的工具栏显示或隐藏，不会影响普通模式下的显示状态，它们的定义是独立的，各不相干。例如可以在全屏下设置不显示状态栏而普通模式下显示状态栏。

2.2.2窗口置顶

右击最小化按钮选择‘总在最前方’可切换窗口到置顶模式。或者是拖拽标签页将弹出一个置顶窗口，查看相关主题。

2.2.3 显示到系统托盘区图标

此项功能可在 高级选项>常规>系统托盘区 设定。其中 在系统托盘区显示世界之窗图标 当浏览器重启后才起效。可设置在页面中按下鼠标中键即最小化到系统托盘区。当显示到系统托盘区时，单击系统托盘区TheWorld浏览器图标即还原窗口。

2.2.4 隐藏窗口（老板键功能）

此项功能可在选项 高级选项>隐私保护>老板键 下启用。启用该功能后，可通过按下指定快捷键隐藏程序窗口（即TheWorld浏览器程序不在任务栏、系统托盘区、任务列表中显示）。默认的老板键为 Ctrl+Q。

· 若是启用了 点击鼠标中键隐藏世界之窗浏览器 而未指定老板键，当隐藏窗口后，可使用默认快捷键 Ctrl+Q 恢复窗口。如果忘记了指定的快捷键，您是无法恢复窗口的，只能在任务管理器的进程列表中结束进程theworld.exe。
· 基于设计老板键的初衷，隐藏后的窗口，只能通过快捷键恢复，再次运行程序将以新的程序实例运行。因此，如果设置为默认浏览器后，您可随意打开网页而无需担心隐藏的窗口被激活。


收藏夹设置

开始使用TheWorld >

收藏夹设置

收藏夹设置

收藏夹是浏览器必不可少的部分，管理好收藏夹有利于提高上网效率。这部分内容主要涉及对收藏夹项目的操作及收藏夹的移植问题。

2.3.1 收藏夹项目

操作收藏夹项目，可在菜单的收藏、工具栏的收藏栏以及侧边栏的收藏夹上进行。如整理收藏夹、拖动排序、删除等。其中‘整理收藏夹’在菜单>收藏夹 打开，而新建文件夹 和 重命名 功能只有在侧边栏上的收藏夹项目上右击才有（如下左图）。

· 点击收藏夹文件夹可选显示 打开目录下全部链接 和 打开目录下我的最爱 （如下右图），这两项可以在 高级选项>收藏夹设置>收藏夹菜单>在收藏夹菜单上显示 里选择是否显示。当然即使取消显示，您也可以通过右击收藏夹文件夹使用此功能。
· 在收藏夹项目上设置为我的最爱，则其被高亮字体颜色显示（如下左图的MSN网址），颜色可在皮肤配置文件中定义。

· 替换为当前网址：用当前打开的标签页网址替换此项目的网址。
· 收藏夹项目拖动可自定义排序，默认按名称自动排列，暂不支持其它方式自动排序。使用‘按字母排序’将重置所有收藏夹项目，若只想重新排序某文件夹下的收藏夹项目，请关闭程序，删除该文件夹下的隐藏文件favsorder.db（显示隐藏文件：我的电脑>工具>文件夹选项>查看>显示隐藏文件和文件夹）

· 收藏夹项目的显示：可选择是否显示其它类型的文件；显示模式可分多列和单列，如图左边为单列。

1) 收藏夹项目默认多列显示，可设置单列显示，列宽宽度可在选项 高级选项>收藏夹设置>收藏夹菜单>收藏夹菜单项最大宽度240像素 设定。
2) 收藏夹项目默认显示网址相关的文件，可设置显示其它类型的文件，如快捷方式、图片等：高级选项>收藏夹设置>高级>在收藏夹中只显示网址相关的文件，不显示其它类型文件。

2.3.2 收藏夹移植

TheWorld浏览器默认使用的是IE的收藏夹，如果您没有修改过系统默认收藏夹路径，那其对应的文件夹一般是C:\Documents and Settings\（您的用户名）\Favorites，所以要导入导出收藏夹内容，直接复制 Favorites下的内容到目的文件夹下即可。当然也可以使用菜单下的‘导入导出…’功能导入或导出为单个的收藏夹文件（如bookmark.htm）。

收藏夹路径

在 高级选项>收藏夹设置>收藏夹路径 下可设定TheWorld浏览器收藏夹的路径，支持相对路径。所谓相对路径，就是以当前目录为参照起点，相对于这个起点目录向上或向下的路径。在相对路径中用符号点（.）代表当前路径，双点（..）代表向上一级目录。这里说的收藏夹相对路径，以theword.exe文件所在的目录为起始目录。比如：theworld.exe所在目录为D:\Programs\TheWorld，要把收藏夹路径指定在D:\MyFavorites下，其相对路径的写法为 .\..\..\MyFavorites（读作 当前目录的上一级目录的再上一级目录下的MyFavorites文件夹）。

收藏栏路径

留空为使用收藏夹路径。这里的相对路径起始目录是收藏夹路径，并不是以theword.exe所在的目录为起始目录。如上例子，假设收藏夹设置的相对路径为 .\..\..\MyFavorites ，而收藏栏设置的相对路径为 .\MyLove ，那么收藏栏真正对应的文件夹应是 D:\MyFavorites\MyLove 。

使用相对路径，我们可以摆脱盘符未知的局限，只要保证theword.exe和收藏夹文件夹的目录层次位置不变，就能保证程序读取到正确的收藏夹内容。这对于把TheWorld浏览器移植到移动磁盘上使用非常方便。

2.3.3 网络收藏夹

网络收藏夹的使用需要先注册一个帐号，在侧边栏的收藏夹项上，可点击网络收藏夹按钮登陆或注册。也可以直接在地址栏上输入 tw:fav 打开网络收藏夹。更多的信息可访问网络收藏夹站点查看。


鼠标手势与快捷键

开始使用TheWorld >

鼠标手势与快捷键

鼠标手势与快捷键

我们常用到 Ctrl+C 复制功能的快捷键，也常用到 Ctrl+鼠标滚轮 来缩放视图，由此而知，快捷键不应该只局限在键盘的组合键上，也应该包括键盘和鼠标的组合键，甚至还可以把鼠标的组合键也并进去，而鼠标手势正是这种由鼠标组合键构成的快捷键。鼠标手势的用法，就是把鼠标右键当作Ctrl键用，按下鼠标右键不放，然后移动鼠标，根据鼠标指针（或是鼠标滚轮）移动的方向不同来实现不同功能。

2.4.1 鼠标手势

该功能默认未启用，可选上菜单 工具>高级工具>鼠标手势 启用，动作的定义可在 高级选项>鼠标动作>鼠标手势 点击动作栏设置。如图，定义 右左 为用IE访问：那么当按下鼠标右键，鼠标指针先向右移动，再向左移动，然后松开右键，就可实现用IE访问当前页功能。

2.4.2 快捷键

打开选项 高级选项>快捷键 可设定F1-F12键的热键网址功能，多个网址用空格或分号(;)分开，网址中的空格使用 %20 代替。如图F3设置打开两个路径含空格的文件夹的写法。

在 高级选项>快捷键>热键命令 中，您可以设定菜单中所有项的快捷方式，此项设置的改变需浏览器重启后才生效。下面是默认的一些快捷方式列表，仅供参考：

F2 Alt + ↑ | 向左切换标签 | F6 | 显示地址栏下拉列表
F3 Alt + ↓ | 向右切换标签 | Alt + C | 打开侧边栏的收藏夹
F4 Ctrl + W Ctrl + F4 | 关闭当前标签 | Ctrl + F | 显示/隐藏查找栏
Ctrl + R | 搜索页面中选取的文字 | Ctrl + B | 显示/隐藏收藏栏
Ctrl+Alt+W | 关闭其它后台标签 | Ctrl + '+' 或' - ' （仅限小键盘） Ctrl + 滚轮 | 页面缩放5%
Ctrl+Shift+W | 关闭所有标签 | Ctrl + Alt + 滚轮 Ctrl + '/' （仅限小键盘） | 页面缩放恢复
Alt + Z Ctrl + E | 恢复被关闭的标签 | Alt + 1 | 保存当前表单
F5 | 刷新当前页面 | Ctrl + Alt + F | 禁用/开启 Flash
Shift + F5 | 刷新所有页面 | Shift + F10 | 打开右键快捷菜单
Ctrl + F5 | 强制刷新（重新从网站上读取） | Ctrl + D | 添加到收藏夹
Alt + → | 前进 | Alt + 左击 Ctrl + Alt + 左击 | 页面元素保存
 |  | Ctrl + Alt + Shift + 左击 | 显示页面元素地址
Alt + ← Backspace | 后退 | Alt + M | 显示 更多 菜单项
Esc | 停止 焦点聚集到地址栏 | Shift +左击链接 拖曳链接 | 在新标签页（窗口）打开链接
Shift + Esc | 停止载入所有页面 | F11 | 切换全屏
Alt + D | 焦点聚集到地址栏 | Ctrl + M | 保存网页为图片


下载管理和代理服务器

开始使用TheWorld >

下载管理和代理服务器

下载管理和代理服务器

TheWorld内建了下载器和代理服务器工具，默认使用的下载工具是浏览器内建的下载器，默认使用的是IE的代理设置，它们分别对应的选项为：高级选项>浏览器设置>下载工具 和 高级选项>代理服务器。自带下载器目前仅对HTTP协议的下载进行接管，其它下载方式仍然使用IE内核内建的下载功能。

2.5.1 下载管理

默认下载工具可在 菜单>工具>下载管理 中快速切换，下载进度信息可点击状态栏的下载小按钮在侧边栏上查看。浏览器可自动检测到系统中已安装的外部下载工具，如果没有检测到，可能原因是您使用的是非安装版（解压版）的下载软件或还不能被TheWorld浏览器认识的下载软件。没有检测到时，请选择“IE内核内建的下载工具”为默认使用的下载工具，然后在下载软件中设置监视浏览器的下载，这样也可被外部下载工具所接管。

· 下载对话框：对话框界面模式可以在简略高级模式之间随意切换，下载任务时若点击‘直接打开’，文件将被下载到上网临时文件夹且直接打开。
· 默认下载属性：在侧边栏的下载管理中点击‘+’按钮，接着在新建任务对话框点击‘更多选项’按钮。在这个对话框，我们可以设值默认的下载路径及线程等。

· 其它下载选项：在侧边栏下载管理上可以看到下载历史记录，若要删除多个记录，使用Ctrl（或Shift）键进行多选，Ctrl+A是全选。历史记录对应的文件是theworld.xml。若在选项中设置显示下载进度信息，则会在浏览器右下方显示如下左图信息，下载完成的项可点击直接打开。

从上面右图的选项中得知：当默认下载工具选择使用世界之窗或外部下载工具时，可禁止接管指定类型的文件下载和自动关闭下载文件产生的无用空白标签（默认使用IE下载工具不能关闭空白标签）；当世界之窗下载器不是当前默认的下载工具时，也能设置在侧边栏和网页右键菜单中，总是显示‘下载管理’和‘使用世界之窗下载’内容，方便我们临时调用内建的下载功能。（注：内建的下载器有时能下载一些其它下载工具无法下载的链接，当您遇到这种链接时不妨一试）

2.5.2 代理服务器

启用代理服务器有两种方式，一种是先在Internet选项>连接>局域网设置 下设置好代理，然后选上 菜单>工具>代理服务器>使用IE代理设置，这种方式才可以使用代理服务器脚本文件；另一种是先在 高级选项>代理服务器>代理列表 中设置好代理，然后在菜单>工具>代理服务器 选择代理。

· 代理列表多条请‘回车’换行分开，代理的格式：IP Address:Port@Protocol#Remark

（注：其中IP地址和端口之间是一个英文输入法下的冒号，Protocol 类型可以是HTTP或SOCKS 两种<不区 分Socks4或Socks5>，# 后是注释内容可写可不写）

· 对于不使用代理的地址，写在第二个输入框中。多个地址使用分号（;）隔开，可以使用通配符星号（*）来匹配IP段和域名段，"<local>"代表本地地址。

· 代理切换后，即时起效，但只有在程序正常退出后才将切换的状态写入配置文件中进行保存。
· 需要帐号验证的代理，启用后在页面浏览时，会弹出输入用户名和密码的提示对话框。


隐私和安全

开始使用TheWorld >

隐私和安全

隐私和安全

世界之窗浏览器独特的安全浏览模式，能有效地防止恶意插件的干扰，当页面在执行程序时，即可通知用户。

2.6.1 清理历史记录

对于安全性要求高的用户，或者是当使用他人电脑浏览网页时，及时的清理上网历史记录是非常必要的，这样可以减低泄露隐私的风险。在 菜单>工具>清理上网记录 中，可交互式的清理某个项目的记录，如下图。如果要设置浏览器关闭时自动清理，在 高级选项>隐私保护>自动清理 下设置。

（注：Cookies记录了网站的登陆信息，若被保留，则下次访问该网站时无需输入帐号信息就可直接登陆，像大多论坛等网站）

2.6.2 安全浏览

启用安全浏览模式可以有效的防止恶意插件的干扰，如禁止外部键盘和消息钩子监听键盘事件，可起到密码防盗保护功能（此功能不适用于Windows9x/Me）。安全浏览模式下将拦截ActiveX控件安装，可将网站加入信任列表白名单排除拦截，暂不支持IE中的信任网站。该模式下还会过滤一些无用脚本错误提示框等。安全浏览对于具有网页安全证书，采用HTTPS协议的网站不进行过滤。

· 浏览窗口防护：对浏览窗口进行保护，以防范恶意程序窃取信息。
· 安全警报功能：对于页面请求的程序执行动作给出提示信息，手动决定是否允许执行。

启用或取消安全浏览，在 菜单>工具>安全浏览 下设置

ActiveX控件的拦截：启用ActiveX插件拦截功能之后，打开需要安装ActiveX插件的页面，在地址栏里将出现盾牌图标，浏览窗口上将出现黄色提示条。点击黄色提示条即可安装ActiveX插件。

对页面执行程序的拦截：只是给出警告信息，并不是对执行的程序是否为病毒进行辨别和查杀。添加到信任区域后下次将不再提示。


杂项选项

开始使用TheWorld >

杂项选项

杂项选项

TheWorld中还提供自动优化性能的功能和错误控制台。自动优化性能可大幅降低浏览器的CPU占用，打开多个标签时，效果明显；错误控制台是供调试页面脚本使用的工具。这些可在菜单的 工具>高级工具 中启用。

高级选项的一些其它选项：

· 当使用Vista且未使用多功能标题条时，对工具条使用Aero效果：在Windows 7或Vista系统下，启用此项，同时关闭多功能标题条（见 高级选项>常规>基本设置>使用多功能标题条），可显示玻璃透明效果。

· 显示工具条按钮的提示信息（Hint）：鼠标指针悬停在工具按钮上时，显示其对应功能的信息描述。

· 使用和IE浏览器相同的User_Agent串：浏览器识别码。某些网站对浏览器做了识别判断限制可能造成无法登陆；若在本机上还运行过其他浏览器（IE核心）登陆某些网站，会经常丢失Cookies。启用此项后可能会解决以上兼容问题。

· 页面内窗口元素不使用Windows视觉样式：控制页面中的按钮等控件是否使用和系统一样的主题风格。

· 在XMLHttpRequest同步模式下也响应消息：开启此项后，对于采用同步模式的Ajax页面，发送request请求的时候当前线程仍然可以响应队列中的消息，避免页面“假死”。但我们不建议您开启这个选项，因为同步模式已经很少有网站使用了。

· 将TheWorld缓冲文件（网站图标等）放置到IE临时文件中：关闭此项，网站图标将放置在和程序文件同目录下的ImgCache文件夹中。

· IE内核文件设置：默认IE临时文件路径是在C:\Documents and Settings\用户名\Local Settings\Temporary Internet Files下。

· 标签使用多线程模式：多线程模式可大幅减少由于某个网页假死导致的整个浏览器假死情况，并且可以在一定程度上提高网页打开速度。（注：取消多线程模式，可能造成很多功能失效，因此不建议取消）
v 标签自动同步输入法：启用该选项，可解决大多数输入法在多线程的程序下兼容不佳的问题。（兼容不佳表现为：每个新开一个标签输入法会自动切换到默认状态，不能记住上一次使用的输入法状态。


界面外观和插件
显示/隐藏 被隐藏的内容

对于界面外观和功能的要求，那是永无止尽的，但是我们可以通过调用外部皮肤个性化程序的外观，通过安装插件来扩展程序功能。下面介绍如何使用皮肤和插件。

皮肤和字体

TheWorld浏览器本身不支持Windows主题风格，默认使用集成在程序内的皮肤主题，可以加载外置的皮肤主题，皮肤主题支持jpg，gif，png等图像格式，推荐使用PNG文件格式，因为PNG支持Alpha通道的透明方式。

皮肤的安装和使用

皮肤主题的获取您可以点击这里，或者访问论坛皮肤资源区。当然您也可以通过说明文档自己制作。

· 皮肤安装：把皮肤主题文件夹，复制到与程序文件（theworld.exe）同一目录下的Skin文件夹下，如果Skin文件夹不存在，请自行新建；如果下载的是压缩包，请先解压。若安装的皮肤主题不能在皮肤列表中显示，请检查skin.ini文件位置的正确性：Skin\皮肤文件夹\skin.ini。如图所示：

· 皮肤使用：如果安装正确，您可以在 菜单>工具>插件和外观>皮肤 的列表中看到新安装的皮肤主题，选择它即可在右边显示其信息及预览效果。点击‘应用’按钮，将立即启用新的皮肤主题，更多的皮肤下载点击‘获得更多…’按钮，点击‘卸载’按钮即删除皮肤文件夹内容到回收站。（注：皮肤主题的名称在skin.ini中定义，并不是皮肤文件夹的名称）

界面字体设置

程序默认使用微软雅黑字体，如果系统中已安装雅黑字体的话。字体默认是在皮肤主题的skin.ini配置文件中指定的，当然您也可以在 菜单>工具>插件和外观>高级>界面使用自设的字体 中设置。字体的大小调整如图所示。（启用菜单使用系统样式会造成一些菜单的宽度将无法控制，如收藏夹项目。）

插件的应用

插件可增强现有的功能，但同时它们也给程序带来不稳定性，当遇到程序异常时，排除插件带来的影响常常是首要的步骤。对于IE工具条插件和系统BHO插件，TheWorld浏览器可以直接识别，但默认不启用。

插件的安装

TheWorld插件的获取您可以点击这里，或者访问论坛插件资源区。当然您也可以通过开发范例自己开发。

· 插件安装：把插件文件夹，复制到与程序文件（theworld.exe）同一目录下的plugin文件夹下，如果plugin文件夹不存在，请自行创建；如果下载的是压缩包，请先解压。若安装的插件不能在插件列表中显示，请检查plugin.ini文件位置的正确性：plugin\插件文件夹\plugin.ini。如图所示：

· 启用/禁用插件：打开 菜单>工具>插件和外观>插件 的对话框，您可以启用和禁用选定的插件，启用禁用插件重新启动程序后才起效。在对话框中您也可以卸载选定的插件，卸载后的插件文件夹将被删除到回收站。（注：插件的名称在plugin.ini中定义，并不是插件文件夹的名称）

插件的使用

插件安装并启用后，根据插件类型（如上图）可找到它们，TheWorld插件一般分状态栏、插件栏和侧边栏插件，当然有些插件并不会以按钮或信息条等实体显示，如一些脚本插件。在主页上可以下载到一些常用的插件，如RSS插件、显示网站IP地址等信息的SysState插件以及记事贴等。


高级应用

这一节的内容，是对前面几节内容的补充，涉及的主题是广告过滤原理、搜索引擎自定义和对配置文件的修改等等，在继续之前建议您先阅读完前面几节内容，对TheWorld有一定的了解程度。

本节内容

Ø 导入导出
Ø 搜索引擎自定义
Ø 代理服务器脚本
Ø 广告过滤规则
Ø 配置文件TheWorld.ini Skin.ini Plugin.ini
Ø IE 渲染模式


导入导出

高级应用 >

导入导出

导入导出

4.1.1 TheWorld移植

TheWorld具有很方便的移植性，无论是系统重装，还是转移到便携式设备（如优盘）上使用，或者是从一台电脑到另一台电脑，都能使迁移后TheWorld配置保持和之前的一样。先来了解一下TheWorld安装文件夹中可能存在的内容：（假设TheWorld安装目录为 C:\TheWorld 2.0 ）

o Favorites：当在 高级选项>收藏夹设置>收藏夹路径 下设定了收藏夹的相对路径为：.\ Favorites 时才有此目录（或绝对路径 C:\TheWorld 2.0\ Favorites，建议使用相对路径）。相对路径的说明参考收藏夹移植。
o ImgCache：程序运行后自动生成，主要存放网站图标文件，可以在高级选项>其它>杂项>将TheWorld缓冲文件放置到IE临时文件中 设定存放位置。建议不更改默认存放位置。
o Languages：安装了多国语言版会有此目录，用于存放语言库文件。
o Medias：当使用页面媒体自动保存（Alt+点击媒体）时，媒体会被默认保存在该文件夹中。在 高级选项>鼠标动作>保存页面元素>按住Alt键后，鼠标左键点击页面元素时自动保存该元素>自动保存路径 可更改默认保存位置。
o Plugin：所有插件都存放在此文件夹中，一般此文件夹需要自行创建。
o Skin：所有皮肤主题都存放在此文件夹中，一般此文件夹需要自行创建。
o dailytips.ini：每日提示信息。由程序自动生成，可在 高级选项>其它>杂项>在欢迎页面上显示每日提示信息 设置关闭显示。
o dltool.ini：该文件用于调试程序对外部下载工具的识别。是外部下载工具的识别列表，默认不需要。
o form.ini：保存表单文件，使用自动填表功能会产生该文件。
o logo.jpg：自定义空白页背景图，还可以是PNG和GIF格式。
o TheWorld.exe：主程序，手动升级时用新版的TheWorld.exe直接覆盖它即完成平滑升级（设置不改变）。
o TheWorld.ini：主程序配置文件，所有的设置（如：广告过滤名单、快捷键和鼠标手势等等）都保存在该文件中，建议您在每次升级之前先备份此文件。
o theworld.ac：增强的地址栏输入提示索引数据库文件。
o TheWorld.xml：下载历史记录，使用TheWorld内建下载器下载时会生成此文件。
o UnInst.exe：TheWorld卸载程序，使用安装版才有此文件。

了解了以上的各个文件和文件夹的作用，对于升级和移植TheWorld也就变得非常简单：

A. 首先，若要保证移植后收藏夹也不变，那么需先自设收藏夹路径，采用相对路径格式，再把IE收藏夹内容移动过来：复制 C:\Documents and Settings\您的用户名\Favorites 下的内容到相对路径的文件夹中（如上图的Favorites文件夹）。或者 直接使用 菜单>文件>导入导出 功能移植收藏夹。
B. 然后，打包整个目录下的内容迁移即可。建议不改变网站图标文件的存放位置，dailytips.ini文件和UnInst.exe文件可以不需要。

4.1.2 其它设置的导入

从其它浏览器的配置移植到TheWorld浏览器中，并没有直观的界面操作，而且也不是所有的配置都能迁移到TheWorld中，这里介绍几个需要批量导入的例子，像网址别名等。这些都是用记事本程序直接修改配置文件TheWorld.ini文件实现的。记事本打开TheWorld.ini后，中括号对应不同设置分类：

· 快捷功能键：在 [ShortCutSite] 下的1 - 12分别对应功能键F1 - F12。
· 搜索引擎的导入：在 [Search] 下，就是定义搜索引擎，某个每个搜索引擎占一行，格式如下：

Google=1:^:http://www.google.com/search?client=aff-cs-worldbrowser&q=%s:^:gg:^:http://www.google.com

其中橙色段字符是搜索引擎名称，绿色段是搜索串，蓝色段是搜索引擎快捷词，紫色段是搜索网站。

· 网址别名的导入：网址别名保存在 [SiteAlias] 下，导入时请注意，需先设定 [Main]下的AliasCount值，如果导入的数量超出这个值会导入失败，所以保证该值大于或等于导入的数量。如图：

· 广告名单的导入：广告名单保存在 [filter] 下，更多内容参考这里。


搜索引擎的搜索串

高级应用 >

搜索引擎的搜索串

搜索引擎的搜索串

为了方便添加搜索引擎，官方主页提供了 中文搜索引擎添加页面 和 英文搜索引擎添加页面（在搜索栏上点击搜索引擎图标>搜索设置>添加更多搜索引擎）。但有时我们想要添加的搜索引擎并不在以上列表中，这时就需要自定义添加（高级选项>地址和搜索栏>搜索引擎>添加），而这之前需要先知道搜索引擎的搜索串，在此我们将介绍如何得到搜索串。

· 要得到搜索串有一个简单直观的的方法：在高级选项中关闭‘在地址框中显示搜索词’，然后在想要添加的搜索页面随意搜索点内容，如图，在百度图片中搜索test，这时在地址栏得到的地址，把其中的关键字部分（即test）用 %s 替换，得到

http://image.baidu.com/i?tn=baiduimage&ct=201326592&cl=2&lm=-1&pv=&word=%s&z=0 即是搜索串。

使用以上得到的搜索串，如果在搜索中文时出现乱码，可以试试使用%us和%rs替换关键字部分。（字母ｕ或者ｒ的作用如图示说明）。

· 大多时候简单直观的方法是无效的，这就需要分析页面代码，打开搜索页面，查看页面源文件（ViewPage插件是TheWorld中很好的分析页面代码工具）。搜索串的结构基本都是：

搜索页面 + ? + 变量1 + & + 变量2 +& + 变量3…

其中多个变量时使用&字符连接，变量位置可以调换，变量是区分大小写的。下面举例说明，如何从代码中分析出搜索串。打开霏凡软件站 ，在源代码中定位到搜索输入处（如图）的代码：

如上图标记所示：

标记1是搜索执行页面；

标记2是关键字“测试”，变量是keyword，那么在搜索串的表示格式为：keyword=%s ；

标记3中 sType 是个多选变量，可选的值在标记3.1和3.2中，搜索条件分‘软件名称’和‘软件简介’；

标记4中的变量是action，值已固定为s，所以它在搜索串的表示格式为：action=s ；

除此之外再没有其他变量影响搜索内容，连合上面分析的内容，组成的搜索串有两个：

http://search.crsky.com/search.asp?keyword=%s&sType=ResName&action=s （按软件名称搜索）

http://search.crsky.com/search.asp?keyword=%s&sType=Content&action=s （按软件简介搜索）

（注：1. 变量一定全都找出来，否则可能无法得到正确的搜索串；2. 并非所有网站都有搜索串）


代理服务器脚本文件

高级应用 >

代理服务器脚本文件
显示/隐藏 被隐藏的内容

代理服务器脚本文件

虽然在高级选项中可以设置代理服务器，但通过脚本可以满足我们对代理服务器设置更高级的需求。比如在公司要使用代理上网，在家则是直接连接，通过配置代理脚本可以自动识别网络网络环境，无需经常切换代理。TheWorld本身不支持代理脚本，但可以借助使用“IE代理设置”使其支持，因此在TheWorld使用代理脚本功能必须先在菜单中选择使用IE代理设置，然后在IE代理设置里指定代理脚本的位置。如图：

用记事本编辑好脚本代码，然后保存为扩展名是pac的文件，指定是本地文件的话格式如下：

file://X:/* （X是盘符，路径的空格用 %20代替，如上右图脚本文件是 C:\TheWorld 2.0\proxy.pac）

关于代理脚本语法资料互联网上有很多，比如这个参考文档，很全面。下面几个实例来源于互联网资料。

查看实例...

1. 在公司代理上网和在家直接上网代理脚本实例：

//proxy.pac 脚本测试例子

function FindProxyForURL(url, host)

{

if ( url.substring(0, 5) != "http:"

&& url.substring(0, 6) != "https:"

&& url.substring(0, 4) != "ftp:")

{

return "DIRECT";

}

if (localHostOrDomainIs(host,"localhost") ||

isInNet(host, "10.208.21.0", "255.255.255.0") ||

isInNet(host, "127.0.0.1", "255.255.255.255"))

{

return "DIRECT";

}

if (isPlainHostName(host))

{

return "DIRECT";

}

else

{

return "PROXY 10.208.21.4:8080;PROXY 10.208.21.5:8080; DIRECT";

}

}

2. isPlainHostName(host)，本例演示判断是否为本地主机，如http://myservername/ 的方式访问，如果是直接连接，否则使用代理。

function FindProxyForURL(url, host)
{
if (isPlainHostName(host))
return "DIRECT";
else
return "PROXY proxy:80";
}

3. dnsDomainIs(host, "")、localHostOrDomainIs(host, "")，本例演示判断访问主机是否属于某个域和某个域名，如果属于.company.com域的主机名，而域名不是www.company.com和home.company.com的就直接连接，否则使用代理访问。

function FindProxyForURL(url, host)
{
if ((isPlainHostName(host) ||
dnsDomainIs(host, ".company.com")) &&
!localHostOrDomainIs(host, "www.company.com") &&
!localHostOrDomainIs(host, "home.company.com"))
return "DIRECT";
else
return "PROXY proxy:80";
}

4. isResolvable(host)，本例演示主机名能否被dns服务器解析，如果能直接访问，否则就通过代理访问。

function FindProxyForURL(url, host)
{
if (isResolvable(host))
return "DIRECT";
else
return "PROXY proxy:80";
}

5. isInNet(host, "", "")，本例演示访问IP是否在某个子网内，如果是就直接访问，否则就通过代理，例子演示访问清华IP段的主页不用代理。

function FindProxyForURL(url, host)
{
if (isInNet(host, "166.111.0.0", "255.255.0.0"))
return "DIRECT";
else
return "PROXY proxy:80";
}

6. shExpMatch(host, "")，本例演示根据主机域名来改变连接类型，本地主机、*.edu、 *.com分别用不同的连接方式。

function FindProxyForURL(url, host)
{
if (isPlainHostName(host))
return "DIRECT";
else if (shExpMatch(host, "*.com"))
return "PROXY comproxy:80";
else if (shExpMatch(host, "*.edu"))
return "PROXY eduproxy:80";
else
return "PROXY proxy:80";
}

7. url.substring()，本例演示根据不同的协议来选择不同的代理，http、https、ftp、gopher分别使用不同的代理。

function FindProxyForURL(url, host)
{
if (url.substring(0, 5) == "http:")
{return "PROXY proxy:80"; }
else if (url.substring(0, 4) == "ftp:")
{return "PROXY fproxy:80";}
else if (url.substring(0, 7) == "gopher:")
{return "PROXY gproxy";}
else if (url.substring(0, 6) == "https:")
{return "PROXY secproxy:8080";}
else
{ return "DIRECT";}
}

8. dnsResolve(host)，本例演示判断访问主机是否某个IP，如果是就使用代理，否则直接连接。

function FindProxyForURL(url, host)
{
if (dnsResolve(host) == "166.111.8.237")
{return "PROXY secproxy:8080";}
else
{return "PROXY proxy:80";}
}

9. myIpAddress()，本例演示判断本地IP是否某个IP，如果是就使用代理，否则直接使用连接。

function FindProxyForURL(url, host)
{
if (myIpAddress() == "166.111.8.238")
{return "PROXY proxy:80"; }
else
{return "DIRECT";}
}

10. dnsDomainLevels(host)，本例演示访问主机的域名级数是几级，就是域名有几个点，如果域名中有点，就通过代理访问，否则直接连接。

function FindProxyForURL(url, host)
{
if (dnsDomainLevels(host) > 0)

// if number of dots in host > 0
{return "PROXY proxy:80";}
return "DIRECT";
}

11. weekdayRange()，本例演示当前日期的范围来改变使用代理，如果是GMT时间周三到周六，使用代理连接，否则直接连接。

function FindProxyForURL(url, host)
{
if(weekdayRange("WED", "SAT", "GMT"))
return "PROXY proxy:80";
else
return "DIRECT";
}

12. 最后一个例子是演示随机使用代理，这样可以好好利用代理服务器。

function FindProxyForURL(url,host)
{
return randomProxy();
}
function randomProxy()
{
switch( Math.floor( Math.random() * 5 ) )
{
case 0:
return "PROXY proxy1:80";
break;
case 1:
return "PROXY proxy2:80";
break;
case 2:
return "PROXY proxy3:80";
break;
case 3:
return "PROXY proxy4:80";
break;
case 4:
return "PROXY proxy5:80";
break;
}
}


广告过滤规则

高级应用 >

广告过滤规则
显示/隐藏 被隐藏的内容

广告过滤规则

由于广告内容的多变性，仅靠通用过滤名单过滤是不足于应付的，因此掌握一些基本的过滤规则知识是非常有必要的。TheWorld广告过滤规则名单支持常规过滤格式和正则表达式。了解更多请参与广告过滤交流。

· 常规过滤格式

直接把过滤链接写入名单，或是借助通配符（?）和（*）完成，? 代表一个任意字符，* 代表多个任意字符，例如某网站，右击广告图片查看其地址，多是 ….com/Ggao/…，广告内容地址的共同特点是含有 Ggao 字符。因此可以在TheWorld广告过滤黑名单里添加一条 *Ggao* 实现过滤该站点很多的广告内容。

但 TheWorld 2.x中使用常规过滤格式的黑名单跟TheWorld 1.x有一些不同，那就是一定要使用引用路径，就是页面源码中引用广告元素的路径。

例如：

TheWorld 论坛的左上角的logo，在 TheWorld 1版本中可以写成：

http://bbs.ioage.com/images/default/logo.gif

TheWorld2.x版本中必须写成跟页面源码里一样的路径才会有效，如下：

images/default/logo.gif

· 正则式过滤

正则表达式的基本语法

.

匹配除换行符 \n 之外的任何单个字符. 要匹配包括 \n 在内的任何字符, 可以使用 [.\n] 模式.

\

转义字符, 用于转义紧跟的字符. 详情请参考转义字符表.

[...]

定义一个字符类, 匹配方括号内的任意一个字符.

字符集中的元字符: "] \ ^ -". 若字符集中需要匹配元字符, 请使用 \元字符.

例: [ab\^c] 可以匹配单个字符 a,b,^或c.

[^...]

定义一个非匹配字符类的开始处, 它表示否定该字符类, 即匹配不在方括号中出现的任何字符.

例: [^abc] 可以匹配 e, 7, z 等除 a, b 和 c 之外的字符.

^

如果 ^ 出现在正则表达式最前边, 它匹配输入字符串的开头.

例: ^[abc] 匹配输入字符串开头的 a, b 或 c , 如 about us, be it, can you?.

$

放在正则表达式的最后, 匹配输入字符串的末端.

例: [0-9]$ 匹配输入字符串末端的一个数字字符, 如 last 9, add 1.

|

"或"分隔符, 分隔多个表达式, 只须匹配其中一个.

例: th(is|at|ese|ose) 可以匹配 this, that, these 或 those.

-

在字符类中, 指定一个字符范围.

例: [0-9] 匹配 0 到 9 的数字.

?

匹配前面的子表达式零次或一次. ? 等价于 {0,1} .

例: do(es)? 可以匹配 do 或 does.

+

匹配前面的子表达式一次或多次. + 等价于 {1,} .

例: zo+ 能匹配 zo 以及 zoo 或者 zoooo, 但不能匹配 z .

*

匹配前面的子表达式零次或多次. * 等价于 {0,} .

例: zo* 能匹配 z 以及 zoo .

{n}

匹配前面的子表达式确定的 n 次. n 是一个非负整数.

例: o{2} 不能匹配 Bob 中的 o , 但是能匹配 food 中的 oo .

{n,}

匹配前面的子表达式至少 n 次. n 是一个非负整数. e{1,} 等价于 e+ , e{0,} 则等价于 e* .

例: e{2,} 不能匹配 Bed 中的 e , 但是能匹配 feel 和 feeeeel 中所有的 e .

{n,m}

匹配前面的子表达式最少 n 次且最多 m 次. n<=m, m 和 n 均为非负整数. 在逗号和两个数字之间不能有空格.

o{0,1} 等价于 o? .

例: o{1,3} 可以匹配 fooooood 中的前三个 o .

??,+?,*?,{n}?,{n,}?,{n,m}?

?,+,*,{n},{n,},{n,m}的非贪婪匹配版本, 非贪婪匹配在匹配时会尽可能匹配较少的字符.

例: 输入字符串为 <abc><def>

使用非贪婪匹配 <.*?> 会匹配 <abc> .

使用贪婪匹配 <.*> 会匹配整个 <abc><def> .

$i

表示前面用 () 捕获的第 i 个子表达式. i = 1, 2, 3...9

例: $1 表示前面用 <a[^>]*?href=(".*?")[^>]*?> 捕获 <a href="http://bbs.ioage.com/">得到的 "http://bbs.ioage.com/" 部分. 用于 replace 及 return 部分

(pattern)

表达式分组操作符. 用于分隔子表达式和返回部分匹配结果. 返回的结果可以在替换操作的时候用 $1 - $10 表示.

例: (\d+,)*\d+ 可以匹配逗号分隔的数字字符串, 如 41 或 1,23,456 .

(?:pattern)

非获取匹配分组, 匹配 pattern 但不返回匹配结果, 这样可以节省资源, 也不容易与获取匹配的结果混淆.

(?=pattern)

肯定正查(Positive Lookahead). 作用类似 $, 匹配任何後缀有符合 pattern 字符串的之前的位置,

这是一个非获取匹配.

例: Windows (?=95|98|NT|2000) 匹配 Windows 2000 中的 Windows, 而不匹配 Windows 3.1 中的 Windows.

最终返回的是 Windows 而不包含 pattern 匹配的 2000 部分.

(?!pattern)

否定正查(Negative Lookahead). 作用类似否定的 $, 匹配任何後缀不符合 pattern 字符串的之前的位置,

这是一个非获取匹配.

例: Windows(?!95|98|NT|2000) 匹配 Windows 3.1 中的 Windows, 但不匹配 Windows 2000 中的 Windows.

最终返回的是 Windows 而不包含 pattern 匹配的 3.1 部分.

正则表达式的转义字符表

\w

表示任意字母和数字, 等价于 [a-zA-Z0-9]

\W

表示任意非字母和数字字符, 等价于[^a-zA-Z0-9]

\s

表示任何空白字符, 包括空格, 制表符, 换页符等等, 等价于 [\f\n\r\t\v]

\S

表示任何非空白字符, 等价于 [^\f\n\r\t\v]

\d

表示任意数字, 等价于 [0-9]

\D

表示任意非数字字符, 等价于 [^0-9]

\b

表示单词边界, 即字母和空格之间的位置. 也可能表示退格键

\B

表示非单词边界

\i

表示前面用 () 包含的第 i 个子表达式. i = 1, 2, 3...9

例: <t(.*?)>caption<\/\1> 可以匹配 <title>caption</title>, 注意里面的 \1

\t

表示制表符

\n

表示换行符

\r

表示回车符

\x##

表示十六进制值为 ## 的字符, ## 必须为两个字符. 正则表达式中使用 ASCII 编码

例: \x41 等价于 A , \x041 则等价于 \x04 后面带一个字符 1

\u####

表示十六进制值为 #### 的 Unicode 字符

例: \u2103 等价于摄氏度符号 ℃


基础篇

广告过滤基础篇

广告过滤基础篇

TheWorld 2 黑名单拦截功能有两种格式：传统方式的黑名单，支持通配符以及正则表达式。和基于正则表达式的HTML页面过滤功能。两种格式都可以在"高级选项>广告过滤>黑名单过滤"中设置。

· 黑名单：TheWorld 2中的黑名单增加了对正则表达式的支持，使用方法就是在过滤项的前后各加一个"/"符号，例如：
/(?:\/|\-|_)(?:\d){2,3}x(?:\d){2,3}[^0-9]+(?:swf|gif|jpg|js)/

(这条可以过滤类似以468X60命名的相对标准的广告尺寸的 flash、gif、jpg 以及 javascript文件)

由于正则表达式的引入，可以更充分的利用黑名单来拦截页面广告，对于希望了解正则表达式的朋友，请参考前面提供的正则表达式的相关资料。

· 白名单：既然有广告过滤的功能，那么在过滤中不可避免的会出现误过滤的现象，因此，TheWorld 2 也提供了相应的白名单的功能，设置依然是在"高级选项>广告过滤>黑名单过滤" 中，这个请注意，不是在下面的网站白名单，为了更好的说明我们已经提供截图，请在下图处设置白名单。

白名单的格式跟黑名单一样支持通配符和正则表达式，区别就在于白名单以@@开头，例如：

@@*.sina.com*/mediaplayer.js*
@@/%(?:AD|88)%/
(第一条是基于通配符的针对新浪视频的白名单，第二条是基于正则表达式的白名单，用来修复一些含有疑似广告而被误过滤的链接)


高级篇

广告过滤高级篇
显示/隐藏 被隐藏的内容

广告过滤高级篇

基于正则表达式的HTML页面过滤功能是 TheWorld 2 新加入的功能之一，目的是可以直接处理 HTML 代码，通过对 HTML 代码内容的过滤，可以更大程度的去掉页面上的广告，比如一些文本内容的广告，或者是通过脚本调用的广告。该功能的高度可定制性用户可以根据自己的需要达到很多特殊效果，比如可以改变网站原始布局，改成自己定制的布局。

基于正则表达式的HTML页面过滤规则的具体格式如下：

#(type)#(url)#(restring)###(replace string)

#ex# //基于正则表达式的所有页面通用的 HTML 页面过滤规则

例：

#ex#<script[^>]*?vodone\.com[^>]*?>[\s\S]*?<\/script>###<!--Ad blocked by TheWorld2-->

(这个可以过滤第一视频的视频广告，对所有网站都有效)

#exd# //基于正则表达式的针对指定网址的 HTML 页面过滤规则

例：

#exd#*.live.com*#<div[^>]*?cAdBannerContainer[^>]*?>[\s\S]*?<\/div>###<!--Ad blocked by TheWorld2-->

(这个是过滤 live 邮箱顶部的广告条，仅对 live.com 的网址有效)

由于 HTML 页面过滤规则是基于正则表达式实现的，所以需要一定的正则表达式的基础，同时也需要一些基本的 HTML 语法基础，关于 HTML 语法知识大家可以参考网络上众多的相关资料。至于编写方法，我们推荐使用这两个工具，借助它们来编写可以达到事半功倍的效果。

EditPlus Text Editor 具有语法高亮功能的多用途文本编辑软件，用它来查看HTML代码是最合适了。

RegexBuddy 一个非常优秀的正则表达式编写软件，有了它可以更方便的编写正则表达式。

举例说明

基于正则表达式的HTML页面过滤规则的具体编写方法，我们选择过滤TheWorld论坛首页的联盟论坛部分，请看下图，图中就是TheWorld论坛首页的联盟论坛部分，请先用TheWorld打开论坛首页找到这个部分：

在代码源文件中查找"联盟论坛"，会找到下面一段代码（这里提供的是用ViewPage插件查看的截图，因为有语法高亮，所以看起来会比较清楚，同时由于页面源代码比较长，所以这里只提供了开头和结束部分，大家可以根据提供的开头和结束部分的代码自行查找源文件获得整段代码）。

开头部分源文件截图：

结束部分源文件截图：

通过分析这个部分代码我们发现TheWorld论坛首页的联盟论坛部分的代码是在如下的表格中：

<table summary="联盟论坛" id="forumlinks" cellpadding="0" cellspacing="0" style="">
......
</table>

再经过分析整个首页的源码我们可以发现，其实上面发现的联盟论坛部分的代码外面还有一个DIV，即如下格式：

<div class="box">

<table summary="联盟论坛" id="forumlinks" cellpadding="0" cellspacing="0" style="">
...…
</table>

</div>

由于这个<div class="box">在页面中具有唯一性，那么我们只要过滤这个DIV就可以过滤掉整个联盟论坛部分，由此根据上面介绍的基于正则表达式的针对指定网址的 HTML 页面过滤规则的具体格式说明，我们可以得到如下的过滤规则：

#exd#*bbs.ioage.com*#<div\sclass="box">[\s\S]*?<\/div>###<!—联盟论坛已过滤-->

现在把上面的规则复制到高级选项>广告过滤>黑名单过滤 的规则输入框中，点击应用后按“Ctrl+F5”来彻底刷新TheWorld论坛首页，看看联盟论坛是不是已经没有了？这里要非常注意的一点就是，在选择要过滤的部分的代码的时候一定要确保被过滤的代码在页面上是唯一的，不然会过滤掉其他不该被过滤的内容，在这里如果您使用RegexBuddy软件的话就可以很方便的查看你编写的被过滤部分的正则表达式是不是仅仅匹配需要被过滤的部分，如果没有使用软件来辅助，您可能需要直接在TheWorld里使用过滤规则来检验效果。


其他应用

广告过滤的其他应用

广告过滤的其它功能

由于TheWorld广告过滤功能的特点我们可以轻易的替换页面上的元素，比如用来改变页面的布局，即替换原始的CSS文件。稍微了解网页制作的都知道，现在很多网页的制作都是DIV+CSS形式的，这其中CSS文件记载了页面上各个部分的位置、大小、颜色等等信息，有些情况下由于页面上有广告等一些内容，原来所设计的页面布局可能并不适合我们阅读，在过滤掉相应的广告之后我们可以修改网页上原来的CSS文件来改善我们的阅读效果，这里我们依然以TheWorld论坛页面做个例子，我们查看论坛页面的源码，在开头部分会发现以下代码：

<linkid="css" rel="stylesheet" type="text/css" href="forumdata/cache/style_7.css" />

其中forumdata/cache/style_7.css就是控制页面布局的CSS文件，我们可以用本地的CSS来替换掉这个文件实现自己所希望的效果，依然是按照前面广告过滤规则的写法：

#exd#*bbs.ioage.com*#<link[^>]*?style_7.css[^>]*?>###<linkid="css" rel="stylesheet" type="text/css" href="$tw2f://theworld/user.css" />

（注：$tw2f是个特殊的参数，并不属于正则表达式，这个参数会直接指向TheWorld主程序所在目录下的filter子目录，filter默认是没有的，需要用户自行创建。通过$tw2f参数就可以直接调用filter目录下的任何文件。如上面例子中的 $tw2f://theworld/user.css，即表示：X:\TheWorld2\filter\theworld\user.css文件，其中X:\TheWorld2表示TheWorld主程序所在目录。用户只需要修改这个user.css文件就可以改变规则所对应的页面的布局。）

此类应用还有很多，比如直接显示Rayfile网络盘下载链接：

#exd#*www. rayfile.com*#(<\/html>)###<script>window.setTimeout=null;showDirectDownload()</script>$1

更多相关的信息可以参考这篇文章

广告过滤常见问题

· 在编写正则表达式的过程中需注意，那就是TheWorld的正则引擎是不区分大小写的，这样也可以给我们省下一些功夫，同时TheWorld的正则引擎是采用的VbScript的正则引擎，不同的引擎所支持的正则表达式是有些区别的，也就是说我们在RegexBuddy软件中测试正常的正则表达式并不一定能在TheWorld中正常使用，所以经过软件测试之后我们一定要在TheWorld里多做几次测试，以确定正则表达式能正常工作。

· 有些朋友可能会碰到已经过滤了广告，但是页面上还是会留下广告大小的空白，这是为什么呢？其实这种情况下最常见的就是过滤掉了广告部分的代码之后页面上相同位置依然有其他HTML标签定义了这个部分的尺寸，比如很多时候广告代码都会放在一个table里面，有的时候这个table本身就指定了宽度或者高度，这种情况下我们可以在原来广告代码的附近查找有height= width= 的元素，找到之后把这个部分的代码也过滤掉，也就解决了广告过滤之后还会有空白的问题。


TheWorld.ini

高级应用 >

主程序的配置文件TheWorld.ini

TheWorld.ini

TheWorld.ini是主程序的配置文件，保存着程序的大部分设置，如工具栏布局、搜索引擎、鼠标手势、快捷键和网址别名等等，我们无需对其直接更改，因为基本上所有参数的调整都可以在界面操作方式下进行。在此需要注意的是：

如果您无权修改该文件（比如被设置为只读属性），设置将无法保存。

如果程序出现异常，特别是升级后，建议您改名或删除此文件测试。

程序运行后会自动生成与程序同名的INI文件（如果该INI不存在的话）。

请勿在程序运行时修改该文件，否则修改无效。

个别参数的调整还没有加入界面操作，如"高品质放大图片算法"的开启，编辑TheWorld.ini，在[OPTION]节中加入 ImgBicubic=1，那么页面中的图片缩放将采用三线性插值算法。


Skin.ini

高级应用 >

皮肤的配置文件Skin.ini
显示/隐藏 被隐藏的内容

Skin.ini

这是皮肤的配置文件，每个皮肤主题都有该文件，且其位置是：TheWorld主程序所在目录\skin\皮肤文件夹\skin.ini 。关于皮肤的创建可以参考官方指南，下面摘录Skin.ini文件范例注释。

皮肤的描述

[General]

Name=TheWorld Default

#皮肤名称

Author=Phoenix Studio

#皮肤作者

Comment=TW 2.0 skin

#皮肤简介，可以写很长的简介，但注意不要换行。

Version=2.4.0.2

#皮肤的版本信息，主要用于世界之窗主站在线安装时的版本识别。

边框和标题条设置

[Wnd]

Corner=9

#标题条的圆角大小，Corner=0为不使用圆角

Border=1

#边框宽度，当设定了边框图像时，用图像绘制边框，否则用[color]FRAME_BORDER绘制

BottomCorner=1

#边框的底边是否园角（0否，1底边使用和标题条一样的圆角矩形）

[TitleBar]

Height=24

#标题条高度，缺省为16

工具栏相关设置

[Rebar]

RowLine=0

#工具栏行线是否开启（0为不显示行线，1为显示单线, 2为显示双线）

#线条的颜色在[color]节中REBAR_LINE，REBAR_LINE2中定义

AddressButtonSpace=4

#转到按钮和网址输入框的距离

SearchButtonSpace=4

#搜索按钮和搜索输入框的距离

BackMode=2

#顶部工具条区域、底部状态条（查找条）区域的背景填充方式

#背景支持五种填充方式：

#1-自适应（自动缩放背景图）

#2-平铺

#3-三段式填充,左右部分原始，中部缩放,横向

#4-三段式填充，左右部分缩放，中部居中原始,横向

#5-三段式填充,左右部分原始，中部平铺,横向和纵向

[ToolBar]

MaskNormal=0

# 对于有按钮图片的工具条以外的小工具条（这些小工具条的特点是，每个按钮都是图标或者文字组成的），绘制按钮普通状态的时候，0表示不绘制它的mask图，1表示绘制；收藏条和菜单条的mask图在[img]节的BTN_MASK，小工具条和插件条的mask图在[img]节的BTN_MASK_MINI

MainCY=35

#主工具栏(标准按钮工具栏)的高度

AddressCY=35

#地址栏的高度

SearchCY=35

#搜索栏高度

#虽然上述三个工具栏默认在一行，但可以给他们设置不同的高度，因为工具栏可能会被拖拽到别的行

favoriteCY=25

#收藏栏高度

ProgressLeft=4

#状态栏进度条，刻度区域离背景图边框的距离，有了这个距离，就可以在进度条两边背景上放上比较漂亮的图了

ProgressGaugeMode=1

#状态栏进度条，刻度部分绘制方式，1为拉伸，2为平铺

#提醒：状态栏进度条图片是由两大部分组成，左半部分为背景，三段式填充1方式绘制，右半部分为刻度

输入框设置

[COMBOBOX]

AdressLeftPad=6

#地址框中图标与地址框左边的留空

AdressImgTextPad=3
#地址框中文字与地址框左边图标间的留空

AdressRightPad=0

#地址框的编辑框右边与地址框右边的留空

AddressBtnRightPad=4

#地址栏状态按钮与右边下拉按钮的留空

SearchLeftPad=5

#搜索框中图标与搜索框左边的留空

SearchImgTextPad=3
#地址框中文字与地址框左边图标间的留空

SearchRightPad=5

#搜索框的编辑框右边与搜索框右边的留空

HisSearchLeftPad=10

#历史搜索框中图标与左边的留空

HisSearchImgTextPad=3

#地址框中文字与地址框左边图标间的留空

HisSearchRightPad=5

#历史搜索框中图标与右边的留空

#注意：上述HisSearchRightPad，SearchRightPad两个参数，如果不写或者值为0的时候，表示使用背景图的1/3宽度作为留空宽度。而AdressRightPad不写或者值为0的时候，表示使用地址框后面的下拉按钮的宽度作为留空宽度。

标签栏和分屏浏览设置

[TabBar]

BackMode=2
#标签栏背景填充方式
#背景支持五种填充方式：
#1-自适应（自动缩放背景图）
#2-平铺
#3-三段式填充,左右部分原始，中部缩放,横向
#4-三段式填充，左右部分缩放，中部居中原始,横向
#5-三段式填充,左右部分原始，中部平铺,横向和纵向

ItemLeft=10

ItemRight=10

#TheWorld的标签是变宽的，每个标签宽度都可能不同

#对于单个标签而言，使用标签图片绘制标签的时候，标签图片左边、右边的这两个区域使用图片的左边右边的原始尺寸绘制

#中间区域的宽度为标签实际宽度减左右宽度，绘制的时候用标签图中部拉伸绘制

VBorder=1

#标签上文字和图标的Y方向的边界高度，用于控制标签上内容垂直方向上的显示位置

PBorder=5

#激活的标签，压住未激活的标签的宽度，TheWorld限制不可以超过5个像素

#此项是个特殊项，大多数皮肤，激活标签和普通标签都是挨着的，此时可以不写这个项目，而如果希望激活标签盖住两边的普通标签，则此项必须写

CBorder=0

#激活的标签的关闭按钮与标签右边的距离

#当存在PBorder的时候，此项值如果与PBorder参数相同，可以实现在切换标签时图标不产生移动，注意，如果此项的值大于5，则激活标签的图标左边距也按此值绘制（标签的图片距离标签左边的缺省距离为5）。

[Browser]

Border=2

#当同时显示多个页面的时候，每个页面的边界尺寸

Spliter=2

#当同时显示多个页面的时候，页面之间的距离

图标元素定义

[ICON]

FAV_DIRECTORY=ico\fav_directory.ico

#收藏夹目录图标，不定义则为系统缺省

FAV_URL= ico\fav_url.ico

#收藏链接默认图标，不定义则为系统缺省

ADDRESS_URL= ico\fav_url.ico

#地址栏输入框和标签条上的网页缺省图标，不定义则为系统默认，即使定义了，如果网页自己有图标的话，仍然显示网页图标

ICON_APP= ico\TheWorlds.ico

#程序显示图标，不定义则为TheWorld缺省的地球图标

ICON_APP_SMALL= ico\TheWorlds.ico

#程序显示图标

ICON_ADD_FAVORITE=addfavorite.ico

#收藏栏，添加本页到收藏夹到图标

SEARCH_ICON=search.ico

#搜索框默认图标，没有取到搜索引擎网站图标的显示方式

图像元素定义

[IMG]

BTN_NEW=btn\new.png

#工具图标－新建标签

BTN_BACKWARD=btn\backward.png

#工具图标－后退

BTN_FORWARD=btn\forward.png

#工具图标－前进

BTN_NAVIHISTORY=btn\navihistory.png

#浏览历史下拉按钮

BTN_STOP=btn\stop.png

#工具图标－停止

BTN_REFRESH=btn\refresh.png

#工具图标－刷新

BTN_HOME=btn\home.png

#工具图标－主页

BTN_SIDEBAR=btn\sidebar.png

#工具图标－侧边栏

BTN_RESTORE=btn\restore.png

#工具图标－恢复

BTN_GO=btn\go.png

#地址栏访问按钮

BTN_ADD_REFRESH=btn\refresh.png
#地址栏附加的刷新按钮（编辑地址栏地址时，该按钮将会变成地址栏附件的访问按钮BTN_ADD_GO）

BTN_SEARCH=btn\search.png

#搜索栏搜索按钮

BTN_TITLE_MIN=btn\title_min.png

#窗口最小化按钮

BTN_TITLE_MAX=btn\title_max.png

#窗口最大化按钮

BTN_TITLE_CLOSE=btn\title_close.png

#窗口关闭按钮

BTN_THUMB= btn\thumb.png

#地址栏输入框的下拉按钮

BTN_MASK= btn\mask.png

#菜单栏收藏栏等的通用按钮效果

BTN_ADDRESSBTN_MASK=btn\mask.png

#地址栏状态按钮的通用按钮效果

BTN_MASK_MINI= btn\maskmini.png

#小工具栏插件栏的通用按钮效果

BTN_DROPDOWN=btn\dropdown.png

#工具条的下拉按钮样式的下拉图

BTN_SIDECLOSE=btn\sideclose.png

#侧边栏关闭按钮

BTN_SIDEMENU=btn\sidemenu.png

#侧边栏下拉菜单按钮

BTN_SIDEMODE=btn\sidemode.png

#侧边栏模式切换按钮

BTN_SELECT=btn\select.png

#侧边栏，下载时的选中项

BG_ADDRESS=bg\address.png

#地址栏背景图

BG_ADDRESSEDIT=bg\edit.bmp

#地址栏输入框背景图

BG_ADDRESS_SAFE=bg\address_safe.png

#当访问的页面是HTTPS协议的时候，地址栏的背景

BG_ADDRESSEDIT_SAFE=bg\edit_safe.bmp

#当访问的页面是HTTPS协议的时候，地址栏输入框的背景

BTN_ADDRESS_THUMB_SAFE= btn\thumb.png

#当访问的页面是HTTPS协议的时候，地址栏下拉按钮图

BTN_ADDRESSITEM=ilist\addressitem.png

#地址栏右侧显示的几种提示图 － 如插件被过滤，如网页有安全证书等

BG_FRAME_BORDER_HT=bg\frame_ht.png

#TheWorld边框图－上边，注：此参数和下面三个参数，仅在定义了TheWorld边框尺寸大于1的时候有效

BG_FRAME_BORDER_HB=bg\frame_hb.png

# TheWorld边框图－下边

BG_FRAME_BORDER_VL=bg\frame_vl.png

# TheWorld边框图－左边

BG_FRAME_BORDER_VR=bg\frame_vr.png

# TheWorld边框图－右边

注意：左边和右边的图是拉伸绘制，上边和下边的图是三段式填充1，左右部分原始，中部缩放，两条边交界部分显示的是上边和下边的图（盖住了左右边的）

BG_MENU_HILIGHT=btn\select.png

#菜单悬停的背景图

BG_MENU=bg\menu_hilight.png

#菜单整体背景图

BG_TOPBAR=bg\topbar.png

#顶部工具栏区域的背景图

BG_BOTTOMBAR=bg\bottombar.png

#底部状态栏区域的背景图

BG_TITLEBAR=bg\titlerbar.png

#标题条背景图

BG_HISTORYEDIT=bg\edit.bmp

#历史输入框的编辑框底图

BG_HISTORY=bg_address.png

#历史查找栏的背景图

BG_COMBOCOOL=bg\combocool.png

#搜索框背景图

BG_SEARCHEDIT=bg\sedit.bmp

#搜索框的编辑框底图

BG_STATUSTOOLBAR=bg\statustoolbar.png

#状态条背景图（建议不指定，这样使用的是BG_BOTTOMBAR）

BG_MENUBAR=bg\menubar.png

#标题条上的菜单栏的背景图（建议不指定，这样当使用多功能标题条的时候，使用的是BG_TITLEBAR ,使用标准的标题条的时候，使用的是BG_TOPBAR）

BG_SIDETOOLBAR=bg\sidetoolbar.png

#侧边栏工具条底图

REBAR_GRIP=other\rb_band.png

#工具栏拖动把手

REBAR_CHEVRON=btn\chevron.png

#小工具条（收藏栏）等的显示更多用的下拉按钮

SIZE_STATUSBAR=other\size_status.png

#右下角面板拉伸把手 － 用于调整TheWorld窗口大小

BTN_SEP=other\sep.png

#工具栏分隔符图

IL_STATUSITEM= ilist\statusitem.png

#状态栏显示图标

IL_MENUICON= ilist\menuicon.png

#菜单选择提示图标

IL_SIDEBARITEM= ilist\sidebaritem.png

#侧边栏收藏夹工具按钮图标

IL_SEARCHHISTORY= ilist\searchhistory.png

#历史查询图标

IL_FINDBARITEM= ilist\findbaritem.png

#页面搜索图标

IL_MINITOOLBAR= ilist\minitoolbar.png

#小工具栏图标

IL_NETFAV=ilist\netfav.png
#网络收藏夹图标

IL_DOWNLOAD= ilist\download.png

#侧边栏下载工具图标

IL_SIDEDEFITEM= ilist\sidedefitem.png

#侧边栏分类图标

IL_ADDONS=ilist\addons.png
#插件和外观对话框项目图标
IL_ACBTN=ilist\acbtn.png
#智能地址栏设置图标

TAB_BG=bg\tabbar.png

#标签栏背景图

TAB_ITEM=bg\item.png

#标签图（四种状态1.正常2.悬停3.激活4.分页浏览，每个部分又分作三份，中间为拉伸宽度）

TAB_BGB= bg\tabbarb.png

#页面标签背景（标签在页面下方显示时用）

TAB_ITEMB= bg\itemb.png

#标签图（标签在页面下方显示时用）

TAB_CLOSE=btn\tab_close.png

#激活标签上的关闭按钮

TAB_BTNLEFT=btn\tab_btnleft.png

#标签工具按钮－左

TAB_BTNRIGHT= btn\tab_btnright.png

#标签工具按钮－右

TAB_BTNCLOSE= btn\tab_btnclose.png

#标签工具按钮－关闭

TAB_BTNLIST= btn\tab_btnlist.png

#标签工具按钮－标签列表

TAB_BTNNEW= btn\tab_btnnew.png

#标签工具按钮－新建

TAB_BTNNEWB= btn\tab_btnnewb.png

#标签工具按钮－新建（标签在页面下方显示时用）

TAB_PROGRESS=other\tab_progress.png

#标签页面进度图，8个状态图标

IMG_SIDEBAND= other\sideband.png

#侧边栏宽度拉伸把手

IMG_PROGRESS= other\img_progress.png

#状态栏页面进度图

IMG_BROWSEMODE=other\img_browsemode.png
#状态栏浏览模式切换按钮

IMG_SIDEOLS= other\sideols.png

#侧边栏堆叠工具栏时的把手显示

IMG_BROWSERHINT=other\browserhint.png
#浏览器提示条的图标
IMG_LOCK=other\lock.png
#标签锁定图标
IMG_INFOWND=other\infownd.png
#下载进度提示关闭按钮
IMG_WAIT=other\wait.png
#网络收藏夹上传、下载时的等待状态图

PREVIEW_BTNCLOSE=preview\btnclose.png
#标签预览界面的标签关闭按钮

颜色配置

[COLOR]

FRAME_BORDER=0x3e73af

#程序窗口边框颜色

TitleTextColor=0x000000

#程序标题文本颜色

TitleTextColor2=0x52677a

#设定标题条在窗口处于未激活状态的时候的文字颜色

ToolBarTextColor=0x0

#工具栏和侧边栏文本颜色

STATUSBAR_TEXT=0x0

#状态栏文本颜色

REBAR_LINE=0xb6b3c1

#工具栏分割线颜色（RowLine=1才能开启）

REBAR_LINE2=0xffffff

#工具栏分割线颜色2（RowLine=2才能开启）

SIDEBAR_TOOLBARBK=0x95bde3

#侧边栏面板底色

SIDEBAR_ITEMBKHOT=0xc1d2e9

#侧边栏面板悬停时底色

SIDEBAR_ITEMBKCUR=0xe3e9f1

#侧边栏面板激活时底色

COMBOTEXT=0x0

#输入框文本颜色

COMBOBK=0xffffff

#输入框底色

COMBOTEXTSAFE=0x0

#安全提示时，输入框文本颜色

COMBOBKSAFE=0xffffef

#安全提示时，输入框底色

COMBOFLOATTEXT=0x306bab

#输入框提示文字颜色,浮动的

BROWSER_BORDER=0x818181

#浏览区边框颜色

BROWSER_BORDERA=0x716ef6

#浏览区边框颜色(双屏时主窗口)

TabFocusText=0x0

#当前浏览的标签文字颜色

TabHotText=0x0

#悬停的标签文字颜色

TabText=0x404040

#未浏览的标签文字颜色

Fav_LoveText=0x335bcc
#我的最爱收藏文本颜色
Fav_LoveHighText=0x335bcc
#悬停的我的最爱收藏文本颜色
PREVIEW_ACTIVEBK=0xe9f6fe
#预览标签界面激活标签的背景色
PREVIEW_ACTIVEITEMBORDER=0xb9d2e5
#预览标签界面激活标签的边框色
PREVIEW_SELECTBK=0xf0f9ff
#预览标签界面鼠标悬停标签的背景色
PREVIEW_ITEMBORDER=0xb9d4e9
#预览标签界面鼠标悬停标签的边框色
PREVIEW_IMAGEBORDER=0x706963
#预览标签界面标签缩略图的边框颜色

菜单和字体相关设置

[Menu]

BKColor=0x76abdc

#菜单底色

HorzBarColor=0x76abdc

#菜单左列图标区底色

TextColor=0x000000

#菜单正常文本颜色

HilightTextColor=0xffffff

#菜单悬停文本颜色

GrayTextColor=

#菜单无效文本颜色

SeparatorColor=0xb6b3c1

#分割线颜色

HilightBorder=0xe7e6eb

#悬停区域边框

HilightBKColor=0x5b7ed4

#悬停区域底色

GrayHilightBKColor=0xd0e0f5

#无效菜单悬停区底色

HightlightGray=0xd0e0f5

#无效菜单悬停色

ImgSize_X=

#图标宽度

ImgSize_Y=

#图标高度

ImagePadding_left=2

#图标左侧空出宽度

ImagePadding_right=2

#图标右侧空出宽度

ImagePadding_top=2

#图标顶部空出高度

TextPadding_left=2

#文字左侧空出宽度

TextPadding_right=16

#文字右侧空出宽度

TextPadding_tb=2

#文字顶不空出高度

[Font]

Normal=12,0,0,0,0,0,0,0,134,0,0,0,0,华文彩云

#普通文字的大小和字体指定，当用户在“工具－插件和外观－高级”选项中指定其他字体时，此项将不起作用

Bold=12,0,0,0,700,0,0,0,134,0,0,0,0,华文彩云

#粗体文字（如窗口标题）可以单独指定大小、粗细和字体


plugin.ini

高级应用 >

插件的配置 plugin.ini

plugin.ini

这是插件的配置文件，每个插件都有该文件，且其位置是：TheWorld主程序所在目录\plugin\插件文件夹\plugin.ini 。关于插件的开发可以参考官方的开发范例，下面简单介绍plugin.ini文件的部分参数。

插件配置文件的描述

[General]

Name= ViewPage

#插件英文名称，可选NameCN=和NameTW=分别指简繁中文名

Author=Ptma

#插件作者

ModuleType=SCRIPT

#插件类型，SCRIPT是脚本类程序，ModuleType=exe是可执行程序，ModuleType=COM 组件类如Dll文件库。

FileName=ViewPage.htm

#执行文件

CLSID= {CEA02041-6734-4c23-9171-B1A1E6BF7856}

# ModuleType=COM时才有，注册ID号。

Type=STATUSBUTTON

#插件位置类别，STATUSBUTTON 是状态栏按钮，STATUSBAR 是状态栏条，SideBar 侧边栏插件，BUTTON是插件栏按钮

Comment=网页资源分析

#插件简介，可以写很长的简介，但注意不要换行。

Version=1.21

#插件的版本信息

NoIcon=1

#不显示图标的插件

HotIcon=viewpage.ico

#插件的图标，鼠标指针移到其上时显示

Icon=viewpage.ico

#插件默认显示的图标

NoAutoRun=1

#插件是否自动运行

StartAfterPageDone=

#插件在页面加载完成后是否运行


IE渲染模式

高级应用 >

IE渲染模式

IE渲染模式

如果系统使用的是IE8，浏览器可在两种渲染模式之间切换，如点击状态栏上的模式切换图标。如果IE版本低于IE8时，选项功能将为灰色不可用。

· IE传统模式
IE8之前的版本采用的渲染模式，如IE7、IE6
能正确显示绝大多数的页面，页面的图像、文本等元素位置不当的问题将被纠正
此模式适合浏览为IE8之前的IE浏览器设计的页面

· IE8标准模式
以最遵循W3C标准的方式渲染页面，此模式下能通过Acid2测试
可能导致一些不遵循W3C标准的页面显示不正确
此模式适合浏览遵循W3C标准的页面


附录

相关网址

世界之窗主页： http://www.ioage.com

世界之窗论坛（中文）： http://bbs.ioage.com/cn/

TheWorld Forum(English)： http://bbs.ioage.com/en/

网络在线收藏夹：http://www.theworld.cn

世界之窗更新日志（中文）：http://www.ioage.com/cn/product-log2.htm

TheWorld Browser Update Log(English)：http://www.ioage.com/en/uplog.htm

世界之窗网址导航：http://i.theworld.cn

凤凰工作室（Phoenix Studio）：http://www.phoenixstudio.org/

联系邮件：tech@ioage.com

作者：无边无际 Feb. 05,2009